{"answers":{"affected":"2 open source packages ship an affected version, including nabeel/phpvms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42569 exists.","fix":"Upgrade nabeel/phpvms to 7.0.6 or later.","what":"CVE-2026-42569 is a critical missing authorization vulnerability in phpvms, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42569 and fix it if it is affected.\n\nWhat it is: CVE-2026-42569 is a critical missing authorization vulnerability in phpvms, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42569 exists.\n\nAffected packages and fixed versions:\n- nabeel/phpvms (Packagist): affected all versions; fixed in 7.0.6\n- nabeel/phpvms (Packagist): affected all versions; fixed in 7.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42569/ (Markdown: https://insights.sbomify.com/CVE-2026-42569/index.md)","id":"CVE-2026-42569","markdown":"https://insights.sbomify.com/CVE-2026-42569/index.md","name":"CVE-2026-42569","record":{"aliases":["GHSA-fv26-4939-62fh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpVMS airline simulator","requires_auth":"none","summary":"Unauthenticated attackers can access a legacy import feature to wipe the entire database in phpVMS.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"phpVMS is a PHP application to run and simulate an airline. Prior to version 7.0.6, a critical vulnerability in phpVMS allowed unauthenticated access to a legacy import feature. This issue has been patched in version 7.0.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-05-11","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2026-05-11T11:29:03Z","kind":"github_poc","ref":"https://github.com/0xredash/CVE-2026-42569","stars":0,"title":"CVE-2026-42569"},{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-42569.yaml","stars":null,"title":"phpVMS \u003c 7.0.6 - Legacy Importer Authorization Bypass"}],"tier":"weaponised"},"has_fix":true,"headline":"phpvms: /importer authorization bypass causing full database wipe","id":"CVE-2026-42569","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Svelte devalue: DoS via sparse array deserialization","id":"CVE-2026-42570"},"packages":[{"ecosystem":"Packagist","fixed":["7.0.6"],"introduced":["0"],"last_affected":[],"package":"nabeel/phpvms","purl":null,"source":"GHSA-fv26-4939-62fh"},{"ecosystem":"Packagist","fixed":["7.0.6"],"introduced":["0"],"last_affected":[],"package":"nabeel/phpvms","purl":"pkg:composer/nabeel/phpvms","source":"GHSA-fv26-4939-62fh"}],"prev":{"headline":"Yamcs Vulnerable to LDAP Injection in LdapAuthModule","id":"CVE-2026-42568"},"products":["phpvms"],"published":"2026-05-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-12","vendors":["phpvms"]},"summary":"Unauthenticated attackers can access a legacy import feature to wipe the entire database in phpVMS.","url":"https://insights.sbomify.com/CVE-2026-42569/"}