{"answers":{"affected":"2 open source packages ship an affected version, including devalue. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42570 in the wild and no public exploit code.","fix":"Upgrade devalue to 5.8.1 or later.","what":"CVE-2026-42570 is a high-severity denial of service vulnerability in sveltejs devalue, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42570 and fix it if it is affected.\n\nWhat it is: CVE-2026-42570 is a high-severity denial of service vulnerability in sveltejs devalue, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42570 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devalue (npm): affected from 5.6.3; fixed in 5.8.1\n- devalue (npm): affected from 5.6.3; fixed in 5.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42570/ (Markdown: https://insights.sbomify.com/CVE-2026-42570/index.md)","id":"CVE-2026-42570","markdown":"https://insights.sbomify.com/CVE-2026-42570/index.md","name":"CVE-2026-42570","record":{"aliases":["CLSA-2026-1778805970","GHSA-77vg-94rm-hx3p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript serialization library","requires_auth":"none","summary":"Attackers can cause excessive memory consumption and denial of service by sending crafted sparse arrays to the devalue library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"devalue","vendor":"svelte"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From version 5.6.3 to before version 5.8.1, devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption. This issue has been patched in version 5.8.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Svelte devalue: DoS via sparse array deserialization","id":"CVE-2026-42570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Privilege Escalation Attack affecting Pelican Web UI","id":"CVE-2026-42571"},"packages":[{"ecosystem":"npm","fixed":["5.8.1"],"introduced":["5.6.3"],"last_affected":[],"package":"devalue","purl":null,"source":"GHSA-77vg-94rm-hx3p"},{"ecosystem":"npm","fixed":["5.8.1"],"introduced":["5.6.3"],"last_affected":[],"package":"devalue","purl":"pkg:npm/devalue","source":"GHSA-77vg-94rm-hx3p"}],"prev":{"headline":"phpvms: /importer authorization bypass causing full database wipe","id":"CVE-2026-42569"},"products":["devalue"],"published":"2026-06-09","related":[{"cvss_score":7.5,"headline":"devalue vulnerable to denial of service due to memory exhaustion in devalue.parse","id":"CVE-2026-22774","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":7.5,"headline":"devalue vulnerable to denial of service due to memory/CPU exhaustion in devalue.parse","id":"CVE-2026-22775","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":6.3,"headline":"devalue has prototype pollution in devalue.parse and devalue.unflatten","id":"CVE-2026-30226","kev_date_added":null,"published":"2026-03-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["sveltejs"]},"summary":"Attackers can cause excessive memory consumption and denial of service by sending crafted sparse arrays to the devalue library.","url":"https://insights.sbomify.com/CVE-2026-42570/"}