# CVE-2026-42574: apko dirFS has a symlink-following path traversal that allows multiple entry points to escape the build root

> Attackers can escape the build root via symlink traversal in apko, potentially modifying host files or executing code during container image builds.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** CLEANSTART-2026-PO41193, GHSA-qq3r-w4hj-gjp6, GO-2026-5589, MINI-9mqh-3x4q-f6gv

## What is CVE-2026-42574?

CVE-2026-42574 is a high-severity path traversal vulnerability in chainguard-dev apko, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

apko allows users to build and publish OCI container images built from apk packages. From version 0.14.8 to before version 1.2.5, a crafted .apk could install a TypeSymlink tar entry whose target pointed outside the build root, and a subsequent directory-creation or file-write entry in the same or later archive could traverse that symlink to reach host paths the build user could write to. This issue has been patched in version 1.2.5.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-42574?

3 open source packages ship an affected version, including chainguard.dev/apko.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/apko` | Go | From 0.14.8 | 1.2.5 |
| `chainguard.dev/apko` | Go | From 0.14.8 | 1.2.5 |
| `chainguard.dev/apko` | Go | From 0.14.8 | 1.2.5 |

## How do I fix CVE-2026-42574?

Upgrade chainguard.dev/apko to 1.2.5 or later.

## Is CVE-2026-42574 being exploited?

There is no known exploitation of CVE-2026-42574 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42574 and fix it if it is affected.

What it is: CVE-2026-42574 is a high-severity path traversal vulnerability in chainguard-dev apko, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42574 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainguard.dev/apko (Go): affected from 0.14.8; fixed in 1.2.5
- chainguard.dev/apko (Go): affected from 0.14.8; fixed in 1.2.5
- chainguard.dev/apko (Go): affected from 0.14.8; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42574/ (Markdown: https://insights.sbomify.com/CVE-2026-42574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42574
- OSV: https://osv.dev/vulnerability/CVE-2026-42574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42574/
Summaries are generated and may contain mistakes; the official description above is the record.
