# CVE-2026-42578: Netty: HTTP Header Injection via HttpProxyHandler Disabled Validation

> Attackers can inject arbitrary HTTP headers into CONNECT requests via Netty's HttpProxyHandler due to disabled validation, potentially bypassing proxy security controls.

- **Severity:** Low 2.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 18 Sep 2026
- **Also known as:** CLEANSTART-2026-AX30429, CLEANSTART-2026-BZ01230, CLEANSTART-2026-KM45055, CLEANSTART-2026-UR63455, DEBIAN-CVE-2026-42578, ECHO-46e7-3ee7-0488, GHSA-45q3-82m4-75jr, MINI-2c9m-98r6-2p9v, MINI-2gp6-h97g-4q2p, MINI-3fvw-3h8q-8w7w, MINI-456c-6prg-9f5p, MINI-4qwv-m4jj-x4r5, MINI-5fxw-frq7-ffrv, MINI-5r4g-wgjv-7wmc, MINI-6688-qxp4-295r, MINI-6f25-293g-rc26, MINI-6mv2-47g2-rm7w, MINI-72j3-25vp-hpg4, MINI-7cwh-pq95-9vrm, MINI-7m7f-jjqf-xp7q, MINI-7mxr-jf65-57mr, MINI-7vw9-w3c7-cj89, MINI-7x4g-5v8j-fgw2, MINI-85r2-q84q-7h7p, MINI-89x3-qp29-557q, MINI-8fj3-58j6-xxhp, MINI-8w2h-73gx-3gxj, MINI-8w37-3cpj-56xw, MINI-9g4f-4f25-qvgx, MINI-9jpr-2h7w-82j8, MINI-9phv-wcww-6f25, MINI-9xqf-v38h-hpm3, MINI-c8mf-3jc8-3w9q, MINI-ch4c-r29w-87wj, MINI-cqm3-jjx3-v6rq, MINI-cw4h-66mg-7qrm, MINI-f57x-fq37-gxpv, MINI-f8jw-hj34-27rp, MINI-h5p4-4wrr-pgjf, MINI-h7fm-mv3m-v72w, MINI-hfr4-vjj4-75q2, MINI-hg2m-vfhj-jw57, MINI-hxg4-67hr-h722, MINI-hxxq-4fvr-h847, MINI-j4v9-59p8-7hv5, MINI-j5r4-jghv-423w, MINI-j78j-75hg-6cj6, MINI-jc25-pmgv-5ch4, MINI-jcg7-w46m-29vm, MINI-jfp9-6jg5-2c46, MINI-jpvv-7xm9-38jp, MINI-m9x9-69qv-7rwg, MINI-mh56-gwgw-6v2c, MINI-mqrm-rm9w-2c85, MINI-p32r-h5vg-7rjg, MINI-p582-8c9q-m453, MINI-p7qg-3jxp-rv9c, MINI-pch8-jpq6-5924, MINI-ppr2-5w2r-qc33, MINI-q2q7-p6v9-23r3, MINI-q49m-6395-cpj9, MINI-q7r2-8f45-rjpv, MINI-qr46-jgfq-x56h, MINI-r5g4-p7cj-rj4r, MINI-r7v6-mj4x-mfg5, MINI-rm2x-pf4h-jm9p, MINI-rm7f-rqhr-rf6r, MINI-v4rg-8j2r-m989, MINI-vjm2-cxqf-282r, MINI-vmg8-j3wr-wpfj, MINI-vmvg-hgrf-pjpx, MINI-wghq-m72w-2j56, MINI-wqvj-m7hc-r778, MINI-x24h-4f37-4f3g, MINI-x354-f623-5hjg, MINI-x6vm-cc2p-f3cc, MINI-x986-62vr-g876, MINI-xcfq-5vpp-7qch, MINI-xfcg-585v-rmxm, MINI-xfjr-m3qr-795p, MINI-xgjj-294r-2jwg, MINI-xgrr-hh2f-p929, MINI-xq2v-mr5f-cjj7, MINI-xvw2-5fww-935h, MINI-xwqh-w5hr-9mq2, RHLW-2026-05e60f2154dee59a, ROOT-APP-MAVEN-CVE-2026-42578, UBUNTU-CVE-2026-42578

## What is CVE-2026-42578?

CVE-2026-42578 is a low-severity vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty's HttpProxyHandler constructs HTTP CONNECT requests with header validation explicitly disabled. The newInitialMessage() method creates headers using DefaultHttpHeadersFactory.headersFactory().withValidation(false), then adds user-provided outboundHeaders without any CRLF validation. This allows an attacker who can influence the outbound headers to inject arbitrary HTTP headers into the CONNECT request sent to the proxy server. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-42578?

4 open source packages ship an affected version, including io.netty:netty-handler-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-handler-proxy` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-handler-proxy` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-handler-proxy` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
| `io.netty:netty-handler-proxy` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |

Products: Netty Netty.

## How do I fix CVE-2026-42578?

Upgrade io.netty:netty-handler-proxy to a fixed version for your release line: 4.1.133.Final or 4.2.13.Final.

## Is CVE-2026-42578 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42578 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42578 and fix it if it is affected.

What it is: CVE-2026-42578 is a low-severity vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42578 exists.

Affected packages and fixed versions:
- io.netty:netty-handler-proxy (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-handler-proxy (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-handler-proxy (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final
- io.netty:netty-handler-proxy (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42578/ (Markdown: https://insights.sbomify.com/CVE-2026-42578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42578
- OSV: https://osv.dev/vulnerability/CVE-2026-42578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42578/
Summaries are generated and may contain mistakes; the official description above is the record.
