# CVE-2026-42580: Netty: HTTP Request Smuggling due to incorrect chunk size parsing

> Attackers can exploit integer overflow in chunk size parsing to perform HTTP request smuggling, bypassing security controls and accessing unauthorized data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** CLEANSTART-2026-BN09286, CLEANSTART-2026-HX67191, CLEANSTART-2026-IL67419, CLEANSTART-2026-QN08817, CLEANSTART-2026-TB70732, DEBIAN-CVE-2026-42580, ECHO-cd0d-6a30-e19d, GHSA-m4cv-j2px-7723, MINI-283x-rw7f-6r78, MINI-2h22-vp33-65g4, MINI-2m83-q8rw-fqch, MINI-2qw8-f6p3-v3h6, MINI-368p-fq9v-h4vp, MINI-39xq-9fhq-j48f, MINI-3c87-vrrq-qrhg, MINI-3pc6-r8m7-7pwr, MINI-3rxq-m6h5-9w4c, MINI-4g8h-xjp2-3j37, MINI-4j73-rr2g-3wcp, MINI-4m86-w967-c77j, MINI-557q-3xc7-h944, MINI-55p7-9m68-h6cg, MINI-5hp4-9hcm-c448, MINI-5r4j-367p-3crc, MINI-6487-qj3g-987m, MINI-69p4-hfvh-fgmf, MINI-6hpv-52j8-2h73, MINI-6jjx-cf7f-6g6g, MINI-6q85-cvhh-w2pr, MINI-6q9w-gcxw-22ff, MINI-7267-5gp7-p6vf, MINI-7hv8-pp6g-qwc8, MINI-7j54-phfm-3pqx, MINI-7vr4-6qv4-fr37, MINI-85vc-4jmc-6jr9, MINI-86wq-4f5j-x4wp, MINI-888r-hc28-h8j7, MINI-89gr-q49v-mrvc, MINI-89wm-7w32-9fjg, MINI-8q7r-2g46-3pjm, MINI-8vxc-r9x7-gcmc, MINI-9262-f7mj-6xg9, MINI-9463-rfg8-gq9w, MINI-9c7p-w6j5-qrxx, MINI-9w2c-228r-887g, MINI-c777-3xr9-j7v4, MINI-cf6v-486m-p69q, MINI-cjqc-2m4r-9c8r, MINI-cp28-3c8p-286p, MINI-crjm-c3x8-3558, MINI-f8mv-p5mq-2684, MINI-ff8j-f9rg-56cm, MINI-fq9v-xmcc-75f8, MINI-fr92-fpf7-v28p, MINI-g6cw-8xfh-5whm, MINI-g8q9-cghh-crwj, MINI-ghpx-2ccp-q8wm, MINI-gphq-hjg8-662m, MINI-grqf-fm8v-h2f3, MINI-gwgg-vjq8-4hx3, MINI-hfqj-h82r-vr4r, MINI-hjq5-9524-54xp, MINI-hr2g-gwp3-2jqx, MINI-j837-rf8p-wf43, MINI-jcp4-962c-w38c, MINI-jfv5-2g4g-9vwp, MINI-m343-2rqw-fx28, MINI-m3fj-7v6v-7c56, MINI-m5v6-g22v-4xmh, MINI-m8r5-gjh7-q3qw, MINI-m9q9-mpwq-62r7, MINI-mj6p-hv9v-j6pm, MINI-mphh-82g3-7jxh, MINI-p25f-qrv3-9vmh, MINI-p7h7-wrh2-qrm4, MINI-pgm9-22fg-r6g6, MINI-pw63-p2p3-25wc, MINI-q43h-7j4c-96vh, MINI-q99f-m776-vm3p, MINI-qc7j-rf35-hx24, MINI-r49c-p857-5wgh, MINI-r877-9xhw-798q, MINI-rf5j-mr32-mcwh, MINI-rgh9-55jm-cvj3, MINI-rpf7-f3q9-9rr5, MINI-rwf8-ch9x-j2gp, MINI-rxmh-674g-c73p, MINI-v769-pw9g-rm4x, MINI-vr3v-6q4q-8p73, MINI-vvfm-87rr-vcfc, MINI-vvgp-x7mj-w65q, MINI-vx7q-fxrm-x4c5, MINI-w7c2-g53j-86x9, MINI-wwfh-ww53-42j4, MINI-wxrc-gxrw-p569, MINI-x3h6-g9xx-jpx9, MINI-x474-jwv7-c5cm, MINI-x54r-8r39-hg22, MINI-xjr5-fqrp-9wcg, MINI-xjw5-5v2r-xjwg, MINI-xm25-gwcg-pfc2, MINI-xw9v-465w-3rxf, ROOT-APP-MAVEN-CVE-2026-42580, UBUNTU-CVE-2026-42580

## What is CVE-2026-42580?

CVE-2026-42580 is a medium-severity vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty's chunk size parser silently overflows int, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-42580?

4 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |

Products: Netty Netty.

## How do I fix CVE-2026-42580?

Upgrade io.netty:netty-codec-http to a fixed version for your release line: 4.1.133.Final or 4.2.13.Final.

## Is CVE-2026-42580 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42580 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42580 and fix it if it is affected.

What it is: CVE-2026-42580 is a medium-severity vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42580 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42580/ (Markdown: https://insights.sbomify.com/CVE-2026-42580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42580
- OSV: https://osv.dev/vulnerability/CVE-2026-42580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42580/
Summaries are generated and may contain mistakes; the official description above is the record.
