# CVE-2026-42582: Netty: HTTP/3 QPACK literal unbounded allocation

> Attackers can cause denial of service in Netty HTTP/3 by sending crafted headers that trigger unbounded memory allocation during decoding.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 May 2026
- **Also known as:** CLEANSTART-2026-CH03473, CLEANSTART-2026-CL78657, CLEANSTART-2026-HC86648, DEBIAN-CVE-2026-42582, ECHO-bdc7-f9f5-fd1d, GHSA-2c5c-chwr-9hqw, MINI-7xv9-rhpr-rp92, MINI-ch5g-c25g-hgrg, MINI-cqgr-7v8c-w3qg, MINI-px39-fg7c-mjjq

## What is CVE-2026-42582?

CVE-2026-42582 is a high-severity denial of service vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final, when decoding header blocks, the non-Huffman branch of io.netty.handler.codec.http3.QpackDecoder#decodeHuffmanEncodedLiteral may execute new byte[length] for a string literal before verifying that length bytes are actually present in the compressed field section. The wire encoding allows a very large length to be expressed in few bytes. There is no check that length <= in.readableBytes() before new byte[length]. This vulnerability is fixed in 4.2.13.Final.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-42582?

2 open source packages ship an affected version, including io.netty:netty-codec-http3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http3` | Maven | From 4.2.0.Final | 4.2.13.Final |
| `io.netty:netty-codec-http3` | Maven | From 4.2.0.Final | 4.2.13.Final |

Products: Netty Netty.

## How do I fix CVE-2026-42582?

Upgrade io.netty:netty-codec-http3 to 4.2.13.Final or later.

## Is CVE-2026-42582 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42582 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42582 and fix it if it is affected.

What it is: CVE-2026-42582 is a high-severity denial of service vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42582 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-http3 (Maven): affected from 4.2.0.Final; fixed in 4.2.13.Final
- io.netty:netty-codec-http3 (Maven): affected from 4.2.0.Final; fixed in 4.2.13.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42582/ (Markdown: https://insights.sbomify.com/CVE-2026-42582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42582
- OSV: https://osv.dev/vulnerability/CVE-2026-42582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42582/
Summaries are generated and may contain mistakes; the official description above is the record.
