# CVE-2026-42586: Netty: CRLF Injection in Netty Redis Codec Encoder

> Attackers can inject arbitrary Redis commands or forge responses via CRLF injection in the Netty Redis codec encoder.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** CLEANSTART-2026-BS28431, CLEANSTART-2026-LT22679, CLEANSTART-2026-TD23067, CLSA-2026-1788193874, CLSA-2026-1788418779, DEBIAN-CVE-2026-42586, GHSA-rgrr-p7gp-5xj7, MINI-v2c2-f7jx-629h, MINI-v5cr-5975-2m2m, MINI-w763-vmfj-rq7w, MINI-xcw5-mwrh-7hc4, UBUNTU-CVE-2026-42586

## What is CVE-2026-42586?

CVE-2026-42586 is a medium-severity vulnerability in Netty Netty, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, the Netty Redis codec encoder (RedisEncoder) writes user-controlled string content directly to the network output buffer without validating or sanitizing CRLF (\r\n) characters. Since the Redis Serialization Protocol (RESP) uses CRLF as the command/response delimiter, an attacker who can control the content of a Redis message can inject arbitrary Redis commands or forge fake responses. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-42586?

4 open source packages ship an affected version, including io.netty:netty-codec-redis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-redis` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-codec-redis` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-codec-redis` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
| `io.netty:netty-codec-redis` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |

Products: Netty Netty.

## How do I fix CVE-2026-42586?

Upgrade io.netty:netty-codec-redis to a fixed version for your release line: 4.1.133.Final or 4.2.13.Final.

## Is CVE-2026-42586 being exploited?

There is no known exploitation of CVE-2026-42586 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42586 and fix it if it is affected.

What it is: CVE-2026-42586 is a medium-severity vulnerability in Netty Netty, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42586 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-redis (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-codec-redis (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-codec-redis (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final
- io.netty:netty-codec-redis (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42586/ (Markdown: https://insights.sbomify.com/CVE-2026-42586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42586
- OSV: https://osv.dev/vulnerability/CVE-2026-42586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42586/
Summaries are generated and may contain mistakes; the official description above is the record.
