CVE-2026-42587 Netty: HttpContentDecompressor maxAllocation bypass via Content-Encoding: br/zstd/snappy enables decompression bomb DoS
Attackers can cause out-of-memory denial of service in Netty by bypassing decompression limits using Brotli, zstd, or snappy encodings.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42587?
CVE-2026-42587 is a high-severity denial of service vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, HttpContentDecompressor accepts a maxAllocation parameter to limit decompression buffer size and prevent decompression bomb attacks. This limit is correctly enforced for gzip and deflate encodings via ZlibDecoder, but is silently ignored when the content encoding is br (Brotli), zstd, or snappy. An attacker can bypass the configured decompression limit by sending a compressed payload with Content-Encoding: br instead of Content-Encoding: gzip, causing unbounded memory allocation and out-of-memory denial of service. The same vulnerability exists in DelegatingDecompressorFrameListener for HTTP/2 connections. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
Which versions are affected by CVE-2026-42587?
8 open source packages ship an affected version, including io.netty:netty-codec-http and io.netty:netty-codec-http2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-codec-http Maven | All versions | 4.1.133.Final |
io.netty:netty-codec-http Maven | All versions | 4.1.133.Final |
io.netty:netty-codec-http Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
io.netty:netty-codec-http Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
io.netty:netty-codec-http2 Maven | All versions | 4.1.133.Final |
io.netty:netty-codec-http2 Maven | All versions | 4.1.133.Final |
2 more packages
io.netty:netty-codec-http2 Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
io.netty:netty-codec-http2 Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
Products include Netty Netty.
How do I fix CVE-2026-42587?
Upgrade io.netty:netty-codec-http to a fixed version for your release line: 4.1.133.Final or 4.2.13.Final.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-42587 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42587 exists.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as CLEANSTART-2026-AN70702, CLEANSTART-2026-GC42713, CLEANSTART-2026-HW60756, CLEANSTART-2026-JP35751, CLEANSTART-2026-UO65217, CLEANSTART-2026-WQ78814 and 100 more.