# CVE-2026-42588: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Remote Code Execution via Jolokia addNetworkConnector

> An authenticated attacker can achieve remote code execution on the Apache ActiveMQ broker by exploiting the Jolokia JMX-HTTP bridge to load malicious Spring XML configurations.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-activemq-2026-42588, DEBIAN-CVE-2026-42588, GHSA-hg6c-8mvr-jqc9, MINI-3445-g9vq-rg27, MINI-4x32-cwgf-7xqp, MINI-hj6f-cv7f-j8w5, MINI-pj2j-p6v6-p663, ROOT-APP-MAVEN-CVE-2026-42588, UBUNTU-CVE-2026-42588

## What is CVE-2026-42588?

CVE-2026-42588 is a high-severity code injection vulnerability in Apache Activemq, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.

Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including
BrokerService.addNetworkConnector(String).

An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter using the "masterslave:// " URL which can allow loading a Spring XML application context using ResourceXmlApplicationContext.
Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().
This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.

Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-42588?

13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.6 |
| `activemq` | Bitnami | All versions | 5.19.7, 6.2.6 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.7 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.6 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.6 |

Products: Apache Activemq, Apache Activemq Broker.

## How do I fix CVE-2026-42588?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.7 or 6.2.6.

## Is CVE-2026-42588 being exploited?

There is no known exploitation of CVE-2026-42588 in the wild and no public exploit code.

Public exploit code:

- https://github.com/strivepan/ActiveMQ-cve-2026-42588-scanner-gui (github_poc): https://github.com/strivepan/ActiveMQ-cve-2026-42588-scanner-gui
- Store vulnerability POC files including CVE-2026-42588 Spring RCE xml payload (github_poc): https://github.com/gentleman567/POC

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42588 and fix it if it is affected.

What it is: CVE-2026-42588 is a high-severity code injection vulnerability in Apache Activemq, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42588 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.6
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.6
- activemq (Bitnami): affected all versions; fixed in 5.19.7, 6.2.6
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.6
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.6
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.7
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42588/ (Markdown: https://insights.sbomify.com/CVE-2026-42588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42588
- OSV: https://osv.dev/vulnerability/CVE-2026-42588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42588/
Summaries are generated and may contain mistakes; the official description above is the record.
