# CVE-2026-42589: Gotenberg: Unauthenticated RCE via ExifTool Metadata Key Injection

> Unauthenticated attackers can execute arbitrary OS commands via ExifTool flag injection in the metadata write endpoint.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-rqgh-gxv4-6657, GO-2026-5636

## What is CVE-2026-42589?

CVE-2026-42589 is a critical command injection vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gotenberg is a Docker-powered stateless API for PDF files. Prior to 8.31.0, Gotenberg's /forms/pdfengines/metadata/write HTTP endpoint accepts a JSON metadata object and passes its keys directly to ExifTool via the go-exiftool library. No validation is performed on key characters. A \n embedded in a JSON key splits the ExifTool stdin stream into a new argument line, allowing an attacker to inject arbitrary ExifTool flags — including -if, which evaluates Perl expressions. This achieves unauthenticated OS command execution in a single HTTP request. The response is HTTP 200 with a valid PDF, making the attack transparent to basic monitoring. This vulnerability is fixed in 8.31.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-42589?

4 open source packages ship an affected version, including github.com/gotenberg/gotenberg/v8 and github.com/gotenberg/gotenberg/v7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | None |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | None |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | None |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions | None |

Products: Thecodingmachine Gotenberg.

## How do I fix CVE-2026-42589?

Upgrade to a fixed version.

## Is CVE-2026-42589 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42589 exists.

Public exploit code:

- POC_CVE-2026-42589 (github_poc): https://github.com/fineman999/POC_CVE-2026-42589
- Gotenberg RCE Chain — CVE-2026-42589 + CVE-2026-40281 (github_poc): https://github.com/HackfutSecRoot/-GOTENBERG-RCE-CHAIN
- CVE-2026-42589 & CVE-2026-40281 - GotenBerg (github_poc): https://github.com/codeb0ssx/CVE-2026-42589xCVE-2026-40281-PoC
- Gotenberg - Command Injection (nuclei): http/cves/2026/CVE-2026-42589.yaml

## Other vulnerabilities in gotenberg

- [CVE-2026-40281](https://insights.sbomify.com/CVE-2026-40281/): Gotenberg vulnerable to argument injection via newlines in ExifTool metadata values (critical 10.0)
- [CVE-2020-13450](https://insights.sbomify.com/CVE-2020-13450/): Path traversal in n/a (critical 9.8)
- [CVE-2020-13451](https://insights.sbomify.com/CVE-2020-13451/): Code injection in n/a (critical 9.8)
- [CVE-2020-13452](https://insights.sbomify.com/CVE-2020-13452/): Privilege escalation in n/a (critical 9.8)
- [CVE-2026-42596](https://insights.sbomify.com/CVE-2026-42596/): Gotenberg: Unauthenticated SSRF via default deny-list bypass in downloadFrom and webhook (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42589 and fix it if it is affected.

What it is: CVE-2026-42589 is a critical command injection vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42589 exists.

Affected packages and fixed versions:
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; no fix listed
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; no fix listed
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; no fix listed
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42589/ (Markdown: https://insights.sbomify.com/CVE-2026-42589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42589
- OSV: https://osv.dev/vulnerability/CVE-2026-42589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42589/
Summaries are generated and may contain mistakes; the official description above is the record.
