# CVE-2026-42590: Gotenberg: ExifTool group-prefix syntax bypasses dangerous-tag blocklist

> Attackers can bypass metadata blocklists to rename, move, or link files on the server, potentially leading to code execution.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-7v3r-m9c8-r855, GO-2026-5234

## What is CVE-2026-42590?

CVE-2026-42590 is a high-severity path traversal vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gotenberg is a Docker-powered stateless API for PDF files. Prior to 8.30.0, The ExifTool metadata write blocklist in Gotenberg can be bypassed using ExifTool's group-prefix syntax, enabling arbitrary file rename, move, hardlink, and symlink creation on the server. ExifTool supports group-prefix syntax where File:FileName is processed identically to FileName -- the prefix is stripped by SetNewValue in Writer.pl before tag matching. The safeKeyPattern regex (^[a-zA-Z0-9\-_.:]+$) allows colons, so prefixed tag names pass validation. Any prefix works: File:FileName, System:Directory, a:HardLink, etc. Additionally, FilePermissions, FileUserID, and FileGroupID pseudo-tags are not blocked at all and can modify file attributes without any prefix. This vulnerability is fixed in 8.30.0.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-42590?

4 open source packages ship an affected version, including github.com/gotenberg/gotenberg/v8 and github.com/gotenberg/gotenberg/v7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | None |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions to 8.29.1 | None |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions to 8.29.1 | None |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions | None |

Products: Thecodingmachine Gotenberg.

## How do I fix CVE-2026-42590?

Upgrade to a fixed version.

## Is CVE-2026-42590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42590 exists.

## Other vulnerabilities in gotenberg

- [CVE-2026-40281](https://insights.sbomify.com/CVE-2026-40281/): Gotenberg vulnerable to argument injection via newlines in ExifTool metadata values (critical 10.0)
- [CVE-2026-42589](https://insights.sbomify.com/CVE-2026-42589/): Gotenberg: Unauthenticated RCE via ExifTool Metadata Key Injection (critical 9.8)
- [CVE-2020-13450](https://insights.sbomify.com/CVE-2020-13450/): Path traversal in n/a (critical 9.8)
- [CVE-2020-13451](https://insights.sbomify.com/CVE-2020-13451/): Code injection in n/a (critical 9.8)
- [CVE-2020-13452](https://insights.sbomify.com/CVE-2020-13452/): Privilege escalation in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42590 and fix it if it is affected.

What it is: CVE-2026-42590 is a high-severity path traversal vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42590 exists.

Affected packages and fixed versions:
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; no fix listed
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions up to 8.29.1; no fix listed
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions up to 8.29.1; no fix listed
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42590/ (Markdown: https://insights.sbomify.com/CVE-2026-42590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42590
- OSV: https://osv.dev/vulnerability/CVE-2026-42590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42590/
Summaries are generated and may contain mistakes; the official description above is the record.
