# CVE-2026-42594: Gotenberg: Unauthenticated denial of service via echo.Context pool reuse in webhook async goroutine

> An unauthenticated attacker can crash the Gotenberg PDF service by triggering a race condition in webhook processing, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 16 May 2026
- **Also known as:** GHSA-r33j-c622-r6qp, GO-2026-5605

## What is CVE-2026-42594?

CVE-2026-42594 is a high-severity vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gotenberg is a Docker-powered stateless API for PDF files. Prior to 8.32.0, the webhook middleware spawns a goroutine that holds a reference to the request's echo.Context after the synchronous handler returns ErrAsyncProcess and Echo recycles the context back to its sync.Pool. When a concurrent request claims the recycled context, c.Reset() clears the store. If the webhook goroutine reaches hardTimeoutMiddleware at that moment, an unchecked type assertion on a nil store entry panics outside any recover() scope, crashing the Gotenberg process. Any anonymous caller reaches the webhook path (default webhook-deny-list filters only the webhook destination, not the submitter). A single-source stress of ~24 webhook requests plus ~60 GET /version requests crashes the process in about two seconds. This vulnerability is fixed in 8.32.0.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-42594?

4 open source packages ship an affected version, including github.com/gotenberg/gotenberg/v8 and github.com/gotenberg/gotenberg/v7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.32.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.32.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.32.0 |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions | None |

Products: Thecodingmachine Gotenberg.

## How do I fix CVE-2026-42594?

Upgrade github.com/gotenberg/gotenberg/v8 to 8.32.0 or later.

## Is CVE-2026-42594 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42594 exists.

## Other vulnerabilities in gotenberg

- [CVE-2026-40281](https://insights.sbomify.com/CVE-2026-40281/): Gotenberg vulnerable to argument injection via newlines in ExifTool metadata values (critical 10.0)
- [CVE-2026-42589](https://insights.sbomify.com/CVE-2026-42589/): Gotenberg: Unauthenticated RCE via ExifTool Metadata Key Injection (critical 9.8)
- [CVE-2020-13450](https://insights.sbomify.com/CVE-2020-13450/): Path traversal in n/a (critical 9.8)
- [CVE-2020-13451](https://insights.sbomify.com/CVE-2020-13451/): Code injection in n/a (critical 9.8)
- [CVE-2020-13452](https://insights.sbomify.com/CVE-2020-13452/): Privilege escalation in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42594 and fix it if it is affected.

What it is: CVE-2026-42594 is a high-severity vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42594 exists.

Affected packages and fixed versions:
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.32.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.32.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.32.0
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42594/ (Markdown: https://insights.sbomify.com/CVE-2026-42594/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42594
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42594
- OSV: https://osv.dev/vulnerability/CVE-2026-42594

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42594/
Summaries are generated and may contain mistakes; the official description above is the record.
