# CVE-2026-42597: Gotenberg: Chromium URL conversion routes read arbitrary files under /tmp via file:// scheme

> Attackers can read arbitrary files from /tmp via file:// scheme in URL conversion routes, exposing other users' data.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-g924-cjx7-2rjw, GO-2026-5395

## What is CVE-2026-42597?

CVE-2026-42597 is a medium-severity server-side request forgery vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gotenberg is a Docker-powered stateless API for PDF files. Prior to 8.32.0, the /forms/chromium/convert/url and /forms/chromium/screenshot/url routes accept url=file:///tmp/... from anonymous callers. The default Chromium deny-list intentionally exempts file:///tmp/ so HTML/Markdown routes can load their own request-local assets, and those routes apply a per-request AllowedFilePrefixes guard to scope the read. The URL routes never set AllowedFilePrefixes, so the scope guard silently skips. Alice enumerates /tmp/, walks Gotenberg's per-request working directories, and reads the raw source files of other in-flight conversions as rendered PDF output. This vulnerability is fixed in 8.32.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-42597?

6 open source packages ship an affected version, including github.com/gotenberg/gotenberg/v7 and github.com/gotenberg/gotenberg/v8. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions | None |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions to 7.10.2 | None |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions to 7.10.2 | None |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.32.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.32.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.32.0 |

Products: Thecodingmachine Gotenberg.

## How do I fix CVE-2026-42597?

Upgrade to a fixed version.

## Is CVE-2026-42597 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42597 exists.

## Other vulnerabilities in gotenberg

- [CVE-2026-40281](https://insights.sbomify.com/CVE-2026-40281/): Gotenberg vulnerable to argument injection via newlines in ExifTool metadata values (critical 10.0)
- [CVE-2026-42589](https://insights.sbomify.com/CVE-2026-42589/): Gotenberg: Unauthenticated RCE via ExifTool Metadata Key Injection (critical 9.8)
- [CVE-2020-13450](https://insights.sbomify.com/CVE-2020-13450/): Path traversal in n/a (critical 9.8)
- [CVE-2020-13451](https://insights.sbomify.com/CVE-2020-13451/): Code injection in n/a (critical 9.8)
- [CVE-2020-13452](https://insights.sbomify.com/CVE-2020-13452/): Privilege escalation in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42597 and fix it if it is affected.

What it is: CVE-2026-42597 is a medium-severity server-side request forgery vulnerability in gotenberg, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42597 exists.

Affected packages and fixed versions:
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions; no fix listed
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions up to 7.10.2; no fix listed
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions up to 7.10.2; no fix listed
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.32.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.32.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42597/ (Markdown: https://insights.sbomify.com/CVE-2026-42597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42597
- OSV: https://osv.dev/vulnerability/CVE-2026-42597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42597/
Summaries are generated and may contain mistakes; the official description above is the record.
