# CVE-2026-42602: azureauthextension Authenticate method does not validate bearer tokens, allowing auth bypass via replay

> Attackers can bypass authentication in OpenTelemetry collectors by replaying valid Azure tokens for any scope, gaining unauthorized access to receivers.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-pjv4-3c63-699f, GO-2026-5544, MINI-24cw-5m99-p29q, MINI-7hpc-cqrm-4fg4, MINI-c286-jr9c-h98x, MINI-x4g4-rmjv-6c9c

## What is CVE-2026-42602?

CVE-2026-42602 is a high-severity authentication bypass vulnerability in open-telemetry opentelemetry-collector-contrib, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

azureauthextension is the Azure Authenticator Extension. From 0.124.0 to 0.150.0, a server-side authentication bypass in azureauthextension allows any party who holds a single valid Azure access token for any scope the collector's configured identity can mint for to authenticate to any OpenTelemetry receiver that uses auth: azure_auth. The extension's Authenticate method does not validate incoming bearer tokens as JWTs. Instead, it calls its own configured credential to obtain an access token and compares the client's token to the result with string equality — and the scope for that server-side token request is taken from the client-supplied Host header. As a result, a token minted for any Azure resource the service principal has ever been issued a token for (ARM, Graph, Key Vault, Storage, etc.) will authenticate to the collector if the attacker picks a matching Host. Tokens are replayable for the full issued lifetime (commonly several hours for managed identity tokens).

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-294 (Authentication Bypass by Capture-replay), CWE-290 (Authentication Bypass by Spoofing), CWE-287 (Improper Authentication), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-42602?

3 open source packages ship an affected version, including github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension` | Go | From 0.124.0 to 0.150.0 | None |
| `github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension` | Go | From 0.124.0 to 0.150.0 | None |
| `github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension` | Go | From 0.124.0 | 0.151.0 |

Products: Opentelemetry Opentelemetry Collector Contrib.

## How do I fix CVE-2026-42602?

Upgrade github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension to 0.151.0 or later.

## Is CVE-2026-42602 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42602 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42602 and fix it if it is affected.

What it is: CVE-2026-42602 is a high-severity authentication bypass vulnerability in open-telemetry opentelemetry-collector-contrib, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42602 exists.

Affected packages and fixed versions:
- github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension (Go): affected from 0.124.0 up to 0.150.0; no fix listed
- github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension (Go): affected from 0.124.0 up to 0.150.0; no fix listed
- github.com/open-telemetry/opentelemetry-collector-contrib/extension/azureauthextension (Go): affected from 0.124.0; fixed in 0.151.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42602/ (Markdown: https://insights.sbomify.com/CVE-2026-42602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42602
- OSV: https://osv.dev/vulnerability/CVE-2026-42602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42602/
Summaries are generated and may contain mistakes; the official description above is the record.
