# CVE-2026-42603: OWASP BLT: pre-commit-fix.yaml executes untrusted fork code via pull_request_target

> Attackers can execute arbitrary code with write permissions by exploiting privileged GitHub Actions workflows that process untrusted fork code.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 May 2026
- **Updated:** 11 May 2026

## What is CVE-2026-42603?

CVE-2026-42603 is a high-severity code injection vulnerability in OWASP-BLT BLT, published on 11 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OWASP BLT is a QA testing and vulnerability disclosure platform that encompasses websites, apps, git repositories, and more. Prior to 2.1.2, .github/workflows/pre-commit-fix.yaml uses pull_request_target (privileged trigger) but checks out and executes code directly from the attacker's fork, enabling RCE with write permissions. This vulnerability is fixed in 2.1.2.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-42603?


## How do I fix CVE-2026-42603?

No fix has been published for CVE-2026-42603 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42603 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42603 and fix it if it is affected.

What it is: CVE-2026-42603 is a high-severity code injection vulnerability in OWASP-BLT BLT, published on 11 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42603 exists.

Affected product: OWASP-BLT BLT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42603/ (Markdown: https://insights.sbomify.com/CVE-2026-42603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42603
- OSV: https://osv.dev/vulnerability/CVE-2026-42603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42603/
Summaries are generated and may contain mistakes; the official description above is the record.
