# CVE-2026-42607: Grav: Remote Code Execution (RCE) via Malicious Plugin ZIP Upload in Direct Install Feature

> An authenticated administrator can achieve remote code execution by uploading a malicious ZIP file via the Direct Install feature, bypassing PHP file restrictions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-w48r-jppp-rcfw

## What is CVE-2026-42607?

CVE-2026-42607 is a critical vulnerability in getgrav grav, published on 11 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.0-beta.2, an authenticated user with administrative privileges can achieve Remote Code Execution (RCE) by uploading a specially crafted ZIP file through the "Direct Install" tool. While the system attempts to block direct .php file uploads, it fails to inspect the contents of uploaded ZIP archives. Once a malicious plugin is extracted, it can execute arbitrary PHP code or drop a persistent web shell on the server. This vulnerability is fixed in 2.0.0-beta.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-42607?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

## How do I fix CVE-2026-42607?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-42607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42607 exists.

Public exploit code:

- Grav CMS 2.0.0-beta.2 -  Remote Code Execution (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42607 and fix it if it is affected.

What it is: CVE-2026-42607 is a critical vulnerability in getgrav grav, published on 11 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42607 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42607/ (Markdown: https://insights.sbomify.com/CVE-2026-42607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42607
- OSV: https://osv.dev/vulnerability/CVE-2026-42607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42607/
Summaries are generated and may contain mistakes; the official description above is the record.
