{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42609 exists.","fix":"Upgrade getgrav/grav to 2.0.0-beta.2 or later.","what":"CVE-2026-42609 is a high-severity vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42609 and fix it if it is affected.\n\nWhat it is: CVE-2026-42609 is a high-severity vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42609 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42609/ (Markdown: https://insights.sbomify.com/CVE-2026-42609/index.md)","id":"CVE-2026-42609","markdown":"https://insights.sbomify.com/CVE-2026-42609/index.md","name":"CVE-2026-42609","record":{"aliases":["GHSA-rr73-568v-28f8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"Low-privileged users can overwrite admin accounts via duplicate usernames, causing privilege de-escalation and administrative denial of service.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav","vendor":"getgrav"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-837","name":"Improper Enforcement of a Single, Unique Action"},{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a business logic vulnerability in the Grav Admin Panel allows a low-privileged user (with only user creation permissions) to overwrite existing accounts, including the primary administrator. By creating a new user with a username that already exists, the system updates the existing account's metadata and permissions instead of rejecting the request. This leads to a Denial of Service (DoS) on administrative functions and Privilege De-escalation of the root account. This vulnerability is fixed in 2.0.0-beta.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav: Administrative Account Disruption and Privilege De-escalation via User Overwrite Logic","id":"CVE-2026-42609","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"getgrav:grav","products":["getgrav:grav"],"type":"business_logic","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Grav: Sensitive Information Disclosure via Accounts Service Bypass","id":"CVE-2026-42610"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-rr73-568v-28f8"},{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-rr73-568v-28f8"}],"prev":{"headline":"Grav: Unauthenticated Path Traversal \u0026 Arbitrary File Write in FormFlash component.","id":"CVE-2026-42608"},"products":["grav"],"published":"2026-05-11","related":[{"cvss_score":10,"headline":"Grav Server Side Template Injection vulnerability","id":"CVE-2023-34251","kev_date_added":null,"published":"2023-06-14"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2025-46199","kev_date_added":null,"published":"2025-07-25"},{"cvss_score":9.3,"headline":"GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2)","id":"CVE-2021-47812","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":9.1,"headline":"Grav may be vulnerable to SSRF attack via Twig Templates","id":"CVE-2025-66844","kev_date_added":null,"published":"2025-12-15"},{"cvss_score":9.1,"headline":"Code Injection in getgrav/grav","id":"CVE-2022-2073","kev_date_added":null,"published":"2022-06-29"},{"cvss_score":8.9,"headline":"Grav: Stored XSS via Tag Injection","id":"CVE-2026-42611","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":8.8,"headline":"Grav: Unauthenticated Path Traversal \u0026 Arbitrary File Write in FormFlash component.","id":"CVE-2026-42608","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["getgrav"]},"summary":"Low-privileged users can overwrite admin accounts via duplicate usernames, causing privilege de-escalation and administrative denial of service.","url":"https://insights.sbomify.com/CVE-2026-42609/"}