# CVE-2026-42609: Grav: Administrative Account Disruption and Privilege De-escalation via User Overwrite Logic

> Low-privileged users can overwrite admin accounts via duplicate usernames, causing privilege de-escalation and administrative denial of service.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-rr73-568v-28f8

## What is CVE-2026-42609?

CVE-2026-42609 is a high-severity vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a business logic vulnerability in the Grav Admin Panel allows a low-privileged user (with only user creation permissions) to overwrite existing accounts, including the primary administrator. By creating a new user with a username that already exists, the system updates the existing account's metadata and permissions instead of rejecting the request. This leads to a Denial of Service (DoS) on administrative functions and Privilege De-escalation of the root account. This vulnerability is fixed in 2.0.0-beta.2.

Weakness: CWE-837 (Improper Enforcement of a Single, Unique Action), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-42609?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

Products: Getgrav Grav.

## How do I fix CVE-2026-42609?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-42609 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42609 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42609 and fix it if it is affected.

What it is: CVE-2026-42609 is a high-severity vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42609 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42609/ (Markdown: https://insights.sbomify.com/CVE-2026-42609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42609
- OSV: https://osv.dev/vulnerability/CVE-2026-42609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42609/
Summaries are generated and may contain mistakes; the official description above is the record.
