{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42611 exists.","fix":"Upgrade getgrav/grav to 2.0.0-beta.2 or later.","what":"CVE-2026-42611 is a high-severity cross-site scripting vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42611 and fix it if it is affected.\n\nWhat it is: CVE-2026-42611 is a high-severity cross-site scripting vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42611 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42611/ (Markdown: https://insights.sbomify.com/CVE-2026-42611/index.md)","id":"CVE-2026-42611","markdown":"https://insights.sbomify.com/CVE-2026-42611/index.md","name":"CVE-2026-42611","record":{"aliases":["GHSA-w8cg-7jcj-4vv2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"Low-privileged users can inject SVG elements to trigger stored XSS, potentially leading to server compromise when admins view the page.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav","vendor":"getgrav"}],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a low-privileged (with the ability to create a page) user can cause XSS with the injection of svg element. The XSS can further be escalated to dump the entire system information available under /admin/config/info whenever a Super Admin visits the page; which can further be chained with the use of admin-nonce to do a complete server compromise (RCE). This vulnerability is fixed in 2.0.0-beta.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav: Stored XSS via Tag Injection","id":"CVE-2026-42611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"getgrav:grav","products":["getgrav:grav"],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Grav: Publisher-Level Stored XSS via Unquoted Event Attributes","id":"CVE-2026-42612"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-w8cg-7jcj-4vv2"},{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-w8cg-7jcj-4vv2"}],"prev":{"headline":"Grav: Sensitive Information Disclosure via Accounts Service Bypass","id":"CVE-2026-42610"},"products":["grav"],"published":"2026-05-11","related":[{"cvss_score":10,"headline":"Grav Server Side Template Injection vulnerability","id":"CVE-2023-34251","kev_date_added":null,"published":"2023-06-14"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2025-46199","kev_date_added":null,"published":"2025-07-25"},{"cvss_score":9.3,"headline":"GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2)","id":"CVE-2021-47812","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":9.1,"headline":"Grav may be vulnerable to SSRF attack via Twig Templates","id":"CVE-2025-66844","kev_date_added":null,"published":"2025-12-15"},{"cvss_score":9.1,"headline":"Code Injection in getgrav/grav","id":"CVE-2022-2073","kev_date_added":null,"published":"2022-06-29"},{"cvss_score":8.8,"headline":"Grav: Unauthenticated Path Traversal \u0026 Arbitrary File Write in FormFlash component.","id":"CVE-2026-42608","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["getgrav"]},"summary":"Low-privileged users can inject SVG elements to trigger stored XSS, potentially leading to server compromise when admins view the page.","url":"https://insights.sbomify.com/CVE-2026-42611/"}