# CVE-2026-42611: Grav: Stored XSS via Tag Injection

> Low-privileged users can inject SVG elements to trigger stored XSS, potentially leading to server compromise when admins view the page.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-w8cg-7jcj-4vv2

## What is CVE-2026-42611?

CVE-2026-42611 is a high-severity cross-site scripting vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a low-privileged (with the ability to create a page) user can cause XSS with the injection of svg element. The XSS can further be escalated to dump the entire system information available under /admin/config/info whenever a Super Admin visits the page; which can further be chained with the use of admin-nonce to do a complete server compromise (RCE). This vulnerability is fixed in 2.0.0-beta.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42611?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

Products: Getgrav Grav.

## How do I fix CVE-2026-42611?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-42611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42611 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42611 and fix it if it is affected.

What it is: CVE-2026-42611 is a high-severity cross-site scripting vulnerability in Getgrav Grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42611 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42611/ (Markdown: https://insights.sbomify.com/CVE-2026-42611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42611
- OSV: https://osv.dev/vulnerability/CVE-2026-42611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42611/
Summaries are generated and may contain mistakes; the official description above is the record.
