# CVE-2026-42613: Grav: Privilege Escalation via Missing Server-Side Validation of groups/access

> Unauthenticated users can gain admin privileges by injecting group fields during registration if specific fields are allowed in the configuration.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-pxm6-mhxr-q4mj

## What is CVE-2026-42613?

CVE-2026-42613 is a critical vulnerability in getgrav grav, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.0-beta.2, the Login::register() method in the Login plugin accepts attacker-controlled groups and access fields from the registration POST data without server-side validation. When registration is enabled and groups or access are included in the configured allowed fields list, an unauthenticated user can self-register with admin.super privileges by injecting these fields into the registration request. This vulnerability is fixed in 2.0.0-beta.2.

Weakness: CWE-862 (Missing Authorization), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-42613?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

## How do I fix CVE-2026-42613?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-42613 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42613 exists.

Public exploit code:

- https://github.com/ivanesk315/CVE-2026-42613 (github_poc): https://github.com/ivanesk315/CVE-2026-42613

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42613 and fix it if it is affected.

What it is: CVE-2026-42613 is a critical vulnerability in getgrav grav, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42613 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42613/ (Markdown: https://insights.sbomify.com/CVE-2026-42613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42613
- OSV: https://osv.dev/vulnerability/CVE-2026-42613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42613/
Summaries are generated and may contain mistakes; the official description above is the record.
