CVE-2026-4267 Query Monitor <= 3.20.3 - Reflected Cross-Site Scripting via Request URI

High 7.2 Published Updated

Unauthenticated attackers can inject arbitrary web scripts via the Request URI, executing code in victim browsers if they click a malicious link.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-4267?

CVE-2026-4267 is a high-severity cross-site scripting vulnerability in johnbillion Query Monitor, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Query Monitor – The developer tools panel for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘$_SERVER['REQUEST_URI']’ parameter in all versions up to, and including, 3.20.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

Weakness: CWE-79

Which versions are affected by CVE-2026-4267?

2 open source packages ship an affected version, including johnbillion/query-monitor.

PackageAffectedFixed in
johnbillion/query-monitor PackagistAll versions3.20.4
johnbillion/query-monitor PackagistAll versions3.20.4

How do I fix CVE-2026-4267?

Upgrade johnbillion/query-monitor to 3.20.4 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-4267 being exploited?

There is no known exploitation of CVE-2026-4267 in the wild and no public exploit code.

Sources

Also known as GHSA-2xr4-chcf-vmvf.

Is CVE-2026-4267 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free