{"answers":{"affected":"2 open source packages ship an affected version, including johnbillion/query-monitor.","exploited":"There is no known exploitation of CVE-2026-4267 in the wild and no public exploit code.","fix":"Upgrade johnbillion/query-monitor to 3.20.4 or later.","what":"CVE-2026-4267 is a high-severity cross-site scripting vulnerability in johnbillion Query Monitor, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-4267 and fix it if it is affected.\n\nWhat it is: CVE-2026-4267 is a high-severity cross-site scripting vulnerability in johnbillion Query Monitor, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-4267 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- johnbillion/query-monitor (Packagist): affected all versions; fixed in 3.20.4\n- johnbillion/query-monitor (Packagist): affected all versions; fixed in 3.20.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-4267/ (Markdown: https://insights.sbomify.com/CVE-2026-4267/index.md)","id":"CVE-2026-4267","markdown":"https://insights.sbomify.com/CVE-2026-4267/index.md","name":"CVE-2026-4267","record":{"aliases":["GHSA-2xr4-chcf-vmvf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can inject arbitrary web scripts via the Request URI, executing code in victim browsers if they click a malicious link.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Query Monitor – The developer tools panel for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘$_SERVER['REQUEST_URI']’ parameter in all versions up to, and including, 3.20.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Query Monitor \u003c= 3.20.3 - Reflected Cross-Site Scripting via Request URI","id":"CVE-2026-4267","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting in WP Go Maps (formerly WP Google Maps)","id":"CVE-2026-4268"},"packages":[{"ecosystem":"Packagist","fixed":["3.20.4"],"introduced":["0"],"last_affected":[],"package":"johnbillion/query-monitor","purl":null,"source":"GHSA-2xr4-chcf-vmvf"},{"ecosystem":"Packagist","fixed":["3.20.4"],"introduced":["0"],"last_affected":[],"package":"johnbillion/query-monitor","purl":"pkg:composer/johnbillion/query-monitor","source":"GHSA-2xr4-chcf-vmvf"}],"prev":{"headline":"WatchGuard Firebox Insecure Deserialization in Fireware Access Portal","id":"CVE-2026-4266"},"products":["Query Monitor"],"published":"2026-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["johnbillion"]},"summary":"Unauthenticated attackers can inject arbitrary web scripts via the Request URI, executing code in victim browsers if they click a malicious link.","url":"https://insights.sbomify.com/CVE-2026-4267/"}