# CVE-2026-4267: Query Monitor <= 3.20.3 - Reflected Cross-Site Scripting via Request URI

> Unauthenticated attackers can inject arbitrary web scripts via the Request URI, executing code in victim browsers if they click a malicious link.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-2xr4-chcf-vmvf

## What is CVE-2026-4267?

CVE-2026-4267 is a high-severity cross-site scripting vulnerability in johnbillion Query Monitor, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Query Monitor – The developer tools panel for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘$_SERVER['REQUEST_URI']’ parameter in all versions up to, and including, 3.20.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-4267?

2 open source packages ship an affected version, including johnbillion/query-monitor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `johnbillion/query-monitor` | Packagist | All versions | 3.20.4 |
| `johnbillion/query-monitor` | Packagist | All versions | 3.20.4 |

## How do I fix CVE-2026-4267?

Upgrade johnbillion/query-monitor to 3.20.4 or later.

## Is CVE-2026-4267 being exploited?

There is no known exploitation of CVE-2026-4267 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4267 and fix it if it is affected.

What it is: CVE-2026-4267 is a high-severity cross-site scripting vulnerability in johnbillion Query Monitor, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4267 in the wild and no public exploit code.

Affected packages and fixed versions:
- johnbillion/query-monitor (Packagist): affected all versions; fixed in 3.20.4
- johnbillion/query-monitor (Packagist): affected all versions; fixed in 3.20.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4267/ (Markdown: https://insights.sbomify.com/CVE-2026-4267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4267
- OSV: https://osv.dev/vulnerability/CVE-2026-4267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4267/
Summaries are generated and may contain mistakes; the official description above is the record.
