{"answers":{"affected":"4 open source packages ship an affected version, including awslabs-aws-api-mcp-server and awslabs.aws-api-mcp-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-4270 in the wild and no public exploit code.","fix":"Upgrade awslabs-aws-api-mcp-server to 1.3.9 or later.","what":"CVE-2026-4270 is a medium-severity path traversal vulnerability in AWS API MCP Server, published on 16 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-4270 and fix it if it is affected.\n\nWhat it is: CVE-2026-4270 is a medium-severity path traversal vulnerability in AWS API MCP Server, published on 16 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-4270 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9\n- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9\n- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9\n- awslabs.aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-4270/ (Markdown: https://insights.sbomify.com/CVE-2026-4270/index.md)","id":"CVE-2026-4270","markdown":"https://insights.sbomify.com/CVE-2026-4270/index.md","name":"CVE-2026-4270","record":{"aliases":["GHSA-2cpp-j2fc-qhp7","PYSEC-2026-162"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AWS API MCP Server","requires_auth":"none","summary":"An attacker can bypass file access restrictions to read arbitrary local files via the AWS API MCP Server.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"aws_api_mcp_server","vendor":"amazon"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-424","name":"Improper Protection of Alternate Path"}],"description":"Improper Protection of Alternate Path exists in the no-access and workdir feature of the AWS API MCP Server versions \u003e= 0.2.14 and \u003c 1.3.9 on all platforms may allow the bypass of intended file access restriction and expose arbitrary local file contents in the MCP client application context.\n\nTo remediate this issue, users should upgrade to version 1.3.9.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AWS API MCP File Access Restriction Bypass","id":"CVE-2026-4270","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Libsoup: libsoup: denial of service via use-after-free in http/2 server","id":"CVE-2026-4271"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.9"],"introduced":["0.2.14"],"last_affected":[],"package":"awslabs-aws-api-mcp-server","purl":null,"source":"GHSA-2cpp-j2fc-qhp7"},{"ecosystem":"PyPI","fixed":["1.3.9"],"introduced":["0.2.14"],"last_affected":[],"package":"awslabs-aws-api-mcp-server","purl":"pkg:pypi/awslabs-aws-api-mcp-server","source":"GHSA-2cpp-j2fc-qhp7"},{"ecosystem":"PyPI","fixed":["1.3.9"],"introduced":["0.2.14"],"last_affected":[],"package":"awslabs-aws-api-mcp-server","purl":"pkg:pypi/awslabs-aws-api-mcp-server","source":"PYSEC-2026-162"},{"ecosystem":"PyPI","fixed":["1.3.9"],"introduced":["0.2.14"],"last_affected":[],"package":"awslabs.aws-api-mcp-server","purl":null,"source":"GHSA-2cpp-j2fc-qhp7"}],"prev":{"headline":"Improper S3 ownership verification in Bedrock AgentCore Starter Toolkit","id":"CVE-2026-4269"},"products":["AWS API MCP Server"],"published":"2026-03-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["AWS"]},"summary":"An attacker can bypass file access restrictions to read arbitrary local files via the AWS API MCP Server.","url":"https://insights.sbomify.com/CVE-2026-4270/"}