# CVE-2026-4270: AWS API MCP File Access Restriction Bypass

> An attacker can bypass file access restrictions to read arbitrary local files via the AWS API MCP Server.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-2cpp-j2fc-qhp7, PYSEC-2026-162

## What is CVE-2026-4270?

CVE-2026-4270 is a medium-severity path traversal vulnerability in AWS API MCP Server, published on 16 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper Protection of Alternate Path exists in the no-access and workdir feature of the AWS API MCP Server versions >= 0.2.14 and < 1.3.9 on all platforms may allow the bypass of intended file access restriction and expose arbitrary local file contents in the MCP client application context.

To remediate this issue, users should upgrade to version 1.3.9.

Weakness: CWE-424 (Improper Protection of Alternate Path)

## Which versions are affected by CVE-2026-4270?

4 open source packages ship an affected version, including awslabs-aws-api-mcp-server and awslabs.aws-api-mcp-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `awslabs-aws-api-mcp-server` | PyPI | From 0.2.14 | 1.3.9 |
| `awslabs-aws-api-mcp-server` | PyPI | From 0.2.14 | 1.3.9 |
| `awslabs-aws-api-mcp-server` | PyPI | From 0.2.14 | 1.3.9 |
| `awslabs.aws-api-mcp-server` | PyPI | From 0.2.14 | 1.3.9 |

Products: Amazon Aws Api Mcp Server.

## How do I fix CVE-2026-4270?

Upgrade awslabs-aws-api-mcp-server to 1.3.9 or later.

## Is CVE-2026-4270 being exploited?

There is no known exploitation of CVE-2026-4270 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4270 and fix it if it is affected.

What it is: CVE-2026-4270 is a medium-severity path traversal vulnerability in AWS API MCP Server, published on 16 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-4270 in the wild and no public exploit code.

Affected packages and fixed versions:
- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9
- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9
- awslabs-aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9
- awslabs.aws-api-mcp-server (PyPI): affected from 0.2.14; fixed in 1.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4270/ (Markdown: https://insights.sbomify.com/CVE-2026-4270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4270
- OSV: https://osv.dev/vulnerability/CVE-2026-4270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4270/
Summaries are generated and may contain mistakes; the official description above is the record.
