CVE-2026-4273 Insufficient token rotation validation in remote cluster invite confirmation

Low 3.7 Published Updated

An authenticated attacker can bypass token rotation in remote cluster invites by reusing the original token, compromising the integrity of the invitation process.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-4273?

CVE-2026-4273 is a low-severity vulnerability in Mattermost Mattermost Server, published on 18 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to validate that the RefreshedToken differs from the original invite token during remote cluster invite confirmation which allows an authenticated attacker to bypass token rotation and reuse the original invite token via sending a crafted invite confirmation with a RefreshedToken matching the original token. Mattermost Advisory ID: MMSA-2026-00575

Weakness: CWE-863

Which versions are affected by CVE-2026-4273?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260313190740-742e0be95074
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260313190740-742e0be95074
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20260313190740-742e0be95074
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.010.11.14
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.010.11.14
github.com/mattermost/mattermost/server/v8 GoFrom 11.5.011.5.2
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 11.5.011.5.2
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260313190740-742e0be95074
github.com/mattermost/mattermost-server GoAll versions5.3.2-0.20260313190740-742e0be95074
github.com/mattermost/mattermost-server GoFrom 10.11.0+incompatible10.11.14+incompatible, 11.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-4273?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260313190740-742e0be95074, 10.11.14 or 11.5.2.

Is CVE-2026-4273 being exploited?

There is no known exploitation of CVE-2026-4273 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-hqpj-f3jh-29vx, GO-2026-5432.

Is CVE-2026-4273 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free