CVE-2026-42782 Apache Syncope: Post-auth RCE via Groovy static
Administrators can execute arbitrary code via malicious Groovy static initializers bypassing sandbox restrictions in Apache Syncope.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42782?
CVE-2026-42782 is a high-severity code injection vulnerability in Apache Syncope, published on 25 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Improper Isolation or Compartmentalization vulnerability in Apache Syncope.
An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.
Weakness: CWE-653
Which versions are affected by CVE-2026-42782?
6 open source packages ship an affected version, including org.apache.syncope.core:syncope-core-spring. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.syncope.core:syncope-core-spring Maven | From 3.0.0-M0 to 3.0.16 | None |
org.apache.syncope.core:syncope-core-spring Maven | From 3.0.0-M0 to 3.0.16 | None |
org.apache.syncope.core:syncope-core-spring Maven | From 4.0.0-M0 | 4.0.6 |
org.apache.syncope.core:syncope-core-spring Maven | From 4.0.0-M0 | 4.0.6 |
org.apache.syncope.core:syncope-core-spring Maven | From 4.1.0-M0 | 4.1.1 |
org.apache.syncope.core:syncope-core-spring Maven | From 4.1.0-M0 | 4.1.1 |
Products include Apache Syncope.
How do I fix CVE-2026-42782?
Upgrade org.apache.syncope.core:syncope-core-spring to a fixed version for your release line: 4.0.6 or 4.1.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-42782 being exploited?
There is no known exploitation of CVE-2026-42782 in the wild and no public exploit code.
Other vulnerabilities in Apache Syncope
- CVE-2026-53405 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask
- CVE-2026-53421 Apache Syncope: Remote Code Execution via Scripted Connector
- CVE-2026-57308 Apache Syncope: SQL injection vulnerability in Audit Events search
- CVE-2026-62183 Apache Syncope: User self-service privilege escalation
- CVE-2026-63071 Apache Syncope: RCE via Groovy Sandbox bypass
Sources
Also known as GHSA-gq7g-vg2q-jvq3.