{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.syncope.core:syncope-core-spring. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42782 in the wild and no public exploit code.","fix":"Upgrade org.apache.syncope.core:syncope-core-spring to a fixed version for your release line: 4.0.6 or 4.1.1.","what":"CVE-2026-42782 is a high-severity code injection vulnerability in Apache Syncope, published on 25 May 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42782 and fix it if it is affected.\n\nWhat it is: CVE-2026-42782 is a high-severity code injection vulnerability in Apache Syncope, published on 25 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42782 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.syncope.core:syncope-core-spring (Maven): affected from 3.0.0-M0 up to 3.0.16; no fix listed\n- org.apache.syncope.core:syncope-core-spring (Maven): affected from 3.0.0-M0 up to 3.0.16; no fix listed\n- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.0.0-M0; fixed in 4.0.6\n- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.0.0-M0; fixed in 4.0.6\n- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.1.0-M0; fixed in 4.1.1\n- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.1.0-M0; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42782/ (Markdown: https://insights.sbomify.com/CVE-2026-42782/index.md)","id":"CVE-2026-42782","markdown":"https://insights.sbomify.com/CVE-2026-42782/index.md","name":"CVE-2026-42782","record":{"aliases":["GHSA-gq7g-vg2q-jvq3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Syncope","requires_auth":"high_privilege","summary":"Administrators can execute arbitrary code via malicious Groovy static initializers bypassing sandbox restrictions in Apache Syncope.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"syncope","vendor":"apache"}],"cvss":{"score":7.2,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-653","name":"Improper Isolation or Compartmentalization"}],"description":"Improper Isolation or Compartmentalization vulnerability in Apache Syncope.\n\nAn administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer.\n\nThis issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.\n\nUsers are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Syncope: Post-auth RCE via Groovy static","id":"CVE-2026-42782","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"Sequoia-openpgp: sequoia-openpgp: cryptographic integrity compromise via key flag confusion","id":"CVE-2026-42784"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["3.0.0-M0"],"last_affected":["3.0.16"],"package":"org.apache.syncope.core:syncope-core-spring","purl":null,"source":"GHSA-gq7g-vg2q-jvq3"},{"ecosystem":"Maven","fixed":[],"introduced":["3.0.0-M0"],"last_affected":["3.0.16"],"package":"org.apache.syncope.core:syncope-core-spring","purl":"pkg:maven/org.apache.syncope.core/syncope-core-spring","source":"GHSA-gq7g-vg2q-jvq3"},{"ecosystem":"Maven","fixed":["4.0.6"],"introduced":["4.0.0-M0"],"last_affected":[],"package":"org.apache.syncope.core:syncope-core-spring","purl":null,"source":"GHSA-gq7g-vg2q-jvq3"},{"ecosystem":"Maven","fixed":["4.0.6"],"introduced":["4.0.0-M0"],"last_affected":[],"package":"org.apache.syncope.core:syncope-core-spring","purl":"pkg:maven/org.apache.syncope.core/syncope-core-spring","source":"GHSA-gq7g-vg2q-jvq3"},{"ecosystem":"Maven","fixed":["4.1.1"],"introduced":["4.1.0-M0"],"last_affected":[],"package":"org.apache.syncope.core:syncope-core-spring","purl":null,"source":"GHSA-gq7g-vg2q-jvq3"},{"ecosystem":"Maven","fixed":["4.1.1"],"introduced":["4.1.0-M0"],"last_affected":[],"package":"org.apache.syncope.core:syncope-core-spring","purl":"pkg:maven/org.apache.syncope.core/syncope-core-spring","source":"GHSA-gq7g-vg2q-jvq3"}],"prev":{"headline":"BIG-IP FastL4 virtual server vulnerability","id":"CVE-2026-42781"},"products":["Apache Syncope"],"published":"2026-05-25","related":[{"cvss_score":9.8,"headline":"Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask","id":"CVE-2026-53405","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: Remote Code Execution via Scripted Connector","id":"CVE-2026-53421","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: SQL injection vulnerability in Audit Events search","id":"CVE-2026-57308","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: User self-service privilege escalation","id":"CVE-2026-62183","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: RCE via Groovy Sandbox bypass","id":"CVE-2026-63071","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Expression Language Injection in Apache Syncope","id":"CVE-2020-1959","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":9.8,"headline":"Injection in Apache Syncope","id":"CVE-2020-1961","kev_date_added":null,"published":"2020-05-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["Apache Software Foundation"]},"summary":"Administrators can execute arbitrary code via malicious Groovy static initializers bypassing sandbox restrictions in Apache Syncope.","url":"https://insights.sbomify.com/CVE-2026-42782/"}