# CVE-2026-42782: Apache Syncope: Post-auth RCE via Groovy static

> Administrators can execute arbitrary code via malicious Groovy static initializers bypassing sandbox restrictions in Apache Syncope.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-gq7g-vg2q-jvq3

## What is CVE-2026-42782?

CVE-2026-42782 is a high-severity code injection vulnerability in Apache Syncope, published on 25 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope.

An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer.

This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.

Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

Weakness: CWE-653 (Improper Isolation or Compartmentalization)

## Which versions are affected by CVE-2026-42782?

6 open source packages ship an affected version, including org.apache.syncope.core:syncope-core-spring. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.syncope.core:syncope-core-spring` | Maven | From 3.0.0-M0 to 3.0.16 | None |
| `org.apache.syncope.core:syncope-core-spring` | Maven | From 3.0.0-M0 to 3.0.16 | None |
| `org.apache.syncope.core:syncope-core-spring` | Maven | From 4.0.0-M0 | 4.0.6 |
| `org.apache.syncope.core:syncope-core-spring` | Maven | From 4.0.0-M0 | 4.0.6 |
| `org.apache.syncope.core:syncope-core-spring` | Maven | From 4.1.0-M0 | 4.1.1 |
| `org.apache.syncope.core:syncope-core-spring` | Maven | From 4.1.0-M0 | 4.1.1 |

Products: Apache Syncope.

## How do I fix CVE-2026-42782?

Upgrade org.apache.syncope.core:syncope-core-spring to a fixed version for your release line: 4.0.6 or 4.1.1.

## Is CVE-2026-42782 being exploited?

There is no known exploitation of CVE-2026-42782 in the wild and no public exploit code.

## Other vulnerabilities in Apache Syncope

- [CVE-2026-53405](https://insights.sbomify.com/CVE-2026-53405/): Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask (critical 9.8)
- [CVE-2026-53421](https://insights.sbomify.com/CVE-2026-53421/): Apache Syncope: Remote Code Execution via Scripted Connector (critical 9.8)
- [CVE-2026-57308](https://insights.sbomify.com/CVE-2026-57308/): Apache Syncope: SQL injection vulnerability in Audit Events search (critical 9.8)
- [CVE-2026-62183](https://insights.sbomify.com/CVE-2026-62183/): Apache Syncope: User self-service privilege escalation (critical 9.8)
- [CVE-2026-63071](https://insights.sbomify.com/CVE-2026-63071/): Apache Syncope: RCE via Groovy Sandbox bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42782 and fix it if it is affected.

What it is: CVE-2026-42782 is a high-severity code injection vulnerability in Apache Syncope, published on 25 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42782 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.syncope.core:syncope-core-spring (Maven): affected from 3.0.0-M0 up to 3.0.16; no fix listed
- org.apache.syncope.core:syncope-core-spring (Maven): affected from 3.0.0-M0 up to 3.0.16; no fix listed
- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.0.0-M0; fixed in 4.0.6
- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.0.0-M0; fixed in 4.0.6
- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.1.0-M0; fixed in 4.1.1
- org.apache.syncope.core:syncope-core-spring (Maven): affected from 4.1.0-M0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42782/ (Markdown: https://insights.sbomify.com/CVE-2026-42782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42782
- OSV: https://osv.dev/vulnerability/CVE-2026-42782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42782/
Summaries are generated and may contain mistakes; the official description above is the record.
