CVE-2026-42797 Apache Syncope: JexlContextBuilder Information Disclosure
Administrators can exploit JEXL expressions in Apache Syncope to access sensitive user information, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42797?
CVE-2026-42797 is a medium-severity vulnerability in Apache Syncope, published on 25 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.
An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Weakness: CWE-202
Which versions are affected by CVE-2026-42797?
6 open source packages ship an affected version, including org.apache.syncope.core:syncope-core-provisioning-api. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.syncope.core:syncope-core-provisioning-api Maven | From 3.0.0-M0 to 3.0.16 | None |
org.apache.syncope.core:syncope-core-provisioning-api Maven | From 3.0.0-M0 to 3.0.16 | None |
org.apache.syncope.core:syncope-core-provisioning-api Maven | From 4.0.0-M0 | 4.0.6 |
org.apache.syncope.core:syncope-core-provisioning-api Maven | From 4.0.0-M0 | 4.0.6 |
org.apache.syncope.core:syncope-core-provisioning-api Maven | From 4.1.0-M0 | 4.1.1 |
org.apache.syncope.core:syncope-core-provisioning-api Maven | From 4.1.0-M0 | 4.1.1 |
Products include Apache Syncope.
How do I fix CVE-2026-42797?
Upgrade org.apache.syncope.core:syncope-core-provisioning-api to a fixed version for your release line: 4.0.6 or 4.1.1.
Is CVE-2026-42797 being exploited?
There is no known exploitation of CVE-2026-42797 in the wild and no public exploit code.
Other vulnerabilities in Apache Syncope
- CVE-2026-53405 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask
- CVE-2026-53421 Apache Syncope: Remote Code Execution via Scripted Connector
- CVE-2026-57308 Apache Syncope: SQL injection vulnerability in Audit Events search
- CVE-2026-62183 Apache Syncope: User self-service privilege escalation
- CVE-2026-63071 Apache Syncope: RCE via Groovy Sandbox bypass
Sources
Also known as GHSA-vr35-jm2f-8wg2.