{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42842 exists.","fix":"Upgrade getgrav/grav to 2.0.0-beta.2 or later.","what":"CVE-2026-42842 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42842 and fix it if it is affected.\n\nWhat it is: CVE-2026-42842 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42842 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42842/ (Markdown: https://insights.sbomify.com/CVE-2026-42842/index.md)","id":"CVE-2026-42842","markdown":"https://insights.sbomify.com/CVE-2026-42842/index.md","name":"CVE-2026-42842","record":{"aliases":["GHSA-c2q3-p4jr-c55f"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS plugin","requires_auth":"low_privilege","summary":"An editor can inject JavaScript via taxonomy fields that executes in an administrator's browser, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The form plugin for Grav adds the ability to create and use forms. Prior to 9.1.0, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Grav CMS Form plugin's select field template. Taxonomy tag and category values are rendered with the Twig |raw filter in the admin panel, bypassing the global autoescape protection. An editor-level user can inject arbitrary JavaScript that executes in any administrator's browser session when they view or edit any page in the admin panel. This vulnerability is fixed in 9.1.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"grav-plugin-form: XSS via Taxonomy Field Values in Admin Panel","id":"CVE-2026-42842","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"grav-plugin-api: Grav API Privilege Escalation to Super Admin","id":"CVE-2026-42843"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-c2q3-p4jr-c55f"},{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-c2q3-p4jr-c55f"}],"prev":{"headline":"Grav: Stored XSS via Markdown media attribute() action in Grav CMS","id":"CVE-2026-42841"},"products":["grav","grav-plugin-form"],"published":"2026-05-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["getgrav"]},"summary":"An editor can inject JavaScript via taxonomy fields that executes in an administrator's browser, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-42842/"}