# CVE-2026-42842: grav-plugin-form: XSS via Taxonomy Field Values in Admin Panel

> An editor can inject JavaScript via taxonomy fields that executes in an administrator's browser, potentially leading to account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-c2q3-p4jr-c55f

## What is CVE-2026-42842?

CVE-2026-42842 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The form plugin for Grav adds the ability to create and use forms. Prior to 9.1.0, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Grav CMS Form plugin's select field template. Taxonomy tag and category values are rendered with the Twig |raw filter in the admin panel, bypassing the global autoescape protection. An editor-level user can inject arbitrary JavaScript that executes in any administrator's browser session when they view or edit any page in the admin panel. This vulnerability is fixed in 9.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42842?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-beta.2 |

## How do I fix CVE-2026-42842?

Upgrade getgrav/grav to 2.0.0-beta.2 or later.

## Is CVE-2026-42842 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42842 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42842 and fix it if it is affected.

What it is: CVE-2026-42842 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 11 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42842 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42842/ (Markdown: https://insights.sbomify.com/CVE-2026-42842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42842
- OSV: https://osv.dev/vulnerability/CVE-2026-42842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42842/
Summaries are generated and may contain mistakes; the official description above is the record.
