{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav-plugin-api. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42843 exists.","fix":"Upgrade getgrav/grav-plugin-api to 1.0.0-beta.15 or later.","what":"CVE-2026-42843 is a high-severity vulnerability in getgrav grav-plugin-api, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42843 and fix it if it is affected.\n\nWhat it is: CVE-2026-42843 is a high-severity vulnerability in getgrav grav-plugin-api, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42843 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav-plugin-api (Packagist): affected all versions; fixed in 1.0.0-beta.15\n- getgrav/grav-plugin-api (Packagist): affected all versions; fixed in 1.0.0-beta.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42843/ (Markdown: https://insights.sbomify.com/CVE-2026-42843/index.md)","id":"CVE-2026-42843","markdown":"https://insights.sbomify.com/CVE-2026-42843/index.md","name":"CVE-2026-42843","record":{"aliases":["GHSA-r945-h4vm-h736"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS plugin","requires_auth":"low_privilege","summary":"Authenticated users can escalate privileges to Super Administrator via insecure direct object reference in the Grav API plugin, leading to full system compromise.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav-plugin-api","vendor":"getgrav"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content, media, configuration, users, and system management. Prior to 1.0.0-beta.15, an insecure direct object reference and logic flaw in the Grav API plugin (UsersController::update) allows any authenticated user with basic API access (api.access) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (admin.super and api.super), leading to full system compromise and potential RCE. This vulnerability is fixed in 1.0.0-beta.15.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"grav-plugin-api: Grav API Privilege Escalation to Super Admin","id":"CVE-2026-42843","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Grav: Low-privileged API users can create super-admin accounts via blueprint-upload","id":"CVE-2026-42844"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.0-beta.15"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav-plugin-api","purl":null,"source":"GHSA-r945-h4vm-h736"},{"ecosystem":"Packagist","fixed":["1.0.0-beta.15"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav-plugin-api","purl":"pkg:composer/getgrav/grav-plugin-api","source":"GHSA-r945-h4vm-h736"}],"prev":{"headline":"grav-plugin-form: XSS via Taxonomy Field Values in Admin Panel","id":"CVE-2026-42842"},"products":["grav-plugin-api"],"published":"2026-05-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["getgrav"]},"summary":"Authenticated users can escalate privileges to Super Administrator via insecure direct object reference in the Grav API plugin, leading to full system compromise.","url":"https://insights.sbomify.com/CVE-2026-42843/"}