# CVE-2026-42843: grav-plugin-api: Grav API Privilege Escalation to Super Admin

> Authenticated users can escalate privileges to Super Administrator via insecure direct object reference in the Grav API plugin, leading to full system compromise.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-r945-h4vm-h736

## What is CVE-2026-42843?

CVE-2026-42843 is a high-severity vulnerability in getgrav grav-plugin-api, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content, media, configuration, users, and system management. Prior to 1.0.0-beta.15, an insecure direct object reference and logic flaw in the Grav API plugin (UsersController::update) allows any authenticated user with basic API access (api.access) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (admin.super and api.super), leading to full system compromise and potential RCE. This vulnerability is fixed in 1.0.0-beta.15.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-42843?

2 open source packages ship an affected version, including getgrav/grav-plugin-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav-plugin-api` | Packagist | All versions | 1.0.0-beta.15 |
| `getgrav/grav-plugin-api` | Packagist | All versions | 1.0.0-beta.15 |

Products: Getgrav Grav-Plugin-Api.

## How do I fix CVE-2026-42843?

Upgrade getgrav/grav-plugin-api to 1.0.0-beta.15 or later.

## Is CVE-2026-42843 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42843 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42843 and fix it if it is affected.

What it is: CVE-2026-42843 is a high-severity vulnerability in getgrav grav-plugin-api, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42843 exists.

Affected packages and fixed versions:
- getgrav/grav-plugin-api (Packagist): affected all versions; fixed in 1.0.0-beta.15
- getgrav/grav-plugin-api (Packagist): affected all versions; fixed in 1.0.0-beta.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42843/ (Markdown: https://insights.sbomify.com/CVE-2026-42843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42843
- OSV: https://osv.dev/vulnerability/CVE-2026-42843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42843/
Summaries are generated and may contain mistakes; the official description above is the record.
