# CVE-2026-42845: Grav: Anonymous Page Content Overwrite via Form File Upload filename Override

> An attacker can overwrite page content via file upload in the Grav form plugin, potentially escalating privileges to super-admin.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-w4rc-p66m-x6qq

## What is CVE-2026-42845?

CVE-2026-42845 is a high-severity vulnerability in getgrav grav-plugin-form, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The form plugin for Grav adds the ability to create and use forms. Prior to 9.1.0 , there is an unauthenticated page-content overwrite via file upload (GHSA-w4rc-p66m-x6qq). Public form uploads now strip path components from the POST-supplied filename and hard-block page-content extensions (`md`, `yaml`, `yml`, `json`, `twig`, `ini`) regardless of the configurable dangerous-extensions list. A permissive `accept` policy combined with the default `destination: self@` could otherwise let an attacker overwrite the page's own `.md` and pivot to super-admin via a `process: save` action. This vulnerability is fixed in 9.1.0.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-42845?

2 open source packages ship an affected version, including getgrav/grav-plugin-form.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav-plugin-form` | Packagist | All versions | 9.1.0 |
| `getgrav/grav-plugin-form` | Packagist | All versions | 9.1.0 |

## How do I fix CVE-2026-42845?

Upgrade getgrav/grav-plugin-form to 9.1.0 or later.

## Is CVE-2026-42845 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42845 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42845 and fix it if it is affected.

What it is: CVE-2026-42845 is a high-severity vulnerability in getgrav grav-plugin-form, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42845 exists.

Affected packages and fixed versions:
- getgrav/grav-plugin-form (Packagist): affected all versions; fixed in 9.1.0
- getgrav/grav-plugin-form (Packagist): affected all versions; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42845/ (Markdown: https://insights.sbomify.com/CVE-2026-42845/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42845
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42845
- OSV: https://osv.dev/vulnerability/CVE-2026-42845

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42845/
Summaries are generated and may contain mistakes; the official description above is the record.
