# CVE-2026-42856: Network-AI: Missing authentication on MCP HTTP endpoint allows unauthenticated privileged tool calls

> Unauthenticated attackers can invoke privileged management tools via the MCP HTTP endpoint, leading to potential system compromise.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-fj4g-2p96-q6m3

## What is CVE-2026-42856?

CVE-2026-42856 is a high-severity missing authorization vulnerability in Jovancoding Network-AI, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Network-AI is a TypeScript/Node.js multi-agent orchestrator. Prior to 5.1.3, the MCP HTTP transport accepts JSON-RPC tools/call requests with no authentication, session, origin, or token check, and dispatches them directly to the orchestrator's tool registry. The default bind address is 0.0.0.0. As a result, any party with network reachability to the service can enumerate and invoke privileged management tools. This vulnerability is fixed in 5.1.3.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-42856?

2 open source packages ship an affected version, including network-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `network-ai` | npm | All versions | 5.1.3 |
| `network-ai` | npm | All versions | 5.1.3 |

## How do I fix CVE-2026-42856?

Upgrade network-ai to 5.1.3 or later.

## Is CVE-2026-42856 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42856 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42856 and fix it if it is affected.

What it is: CVE-2026-42856 is a high-severity missing authorization vulnerability in Jovancoding Network-AI, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42856 exists.

Affected packages and fixed versions:
- network-ai (npm): affected all versions; fixed in 5.1.3
- network-ai (npm): affected all versions; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42856/ (Markdown: https://insights.sbomify.com/CVE-2026-42856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42856
- OSV: https://osv.dev/vulnerability/CVE-2026-42856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42856/
Summaries are generated and may contain mistakes; the official description above is the record.
