# CVE-2026-42859: Neat VNC: Buffer overflow due to oversized RSA public keys

> An unauthenticated remote attacker can crash the VNC server by sending oversized RSA public keys, causing a stack buffer overflow.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** DEBIAN-CVE-2026-42859, GHSA-567c-gpv8-qh9h, UBUNTU-CVE-2026-42859

## What is CVE-2026-42859?

CVE-2026-42859 is a high-severity memory corruption vulnerability in any1 neatvnc, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Neat VNC is a VNC server library. Prior to 0.9.6, a pre-authentication stack buffer overflow exists in neatvnc in the RSA-AES security type handler. An unauthenticated remote attacker who can reach the VNC listening socket can send a crafted security type 5 (RSA-AES) or security type 129 (RSA-AES-256) handshake with an oversized client RSA public key, causing rsa_aes_send_challenge in src/auth/rsa-aes.c to overflow a 1024-byte on-stack buffer when encrypting the server challenge. This results in at least a denial of service via server crash. This vulnerability is fixed in 0.9.6.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2026-42859?


## How do I fix CVE-2026-42859?

Upgrade to a fixed version.

## Is CVE-2026-42859 being exploited?

There is no known exploitation of CVE-2026-42859 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42859 and fix it if it is affected.

What it is: CVE-2026-42859 is a high-severity memory corruption vulnerability in any1 neatvnc, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42859 in the wild and no public exploit code.

Affected product: any1 neatvnc. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42859/ (Markdown: https://insights.sbomify.com/CVE-2026-42859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42859
- OSV: https://osv.dev/vulnerability/CVE-2026-42859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42859/
Summaries are generated and may contain mistakes; the official description above is the record.
