CVE-2026-4286 Playbooks Plugin fails to validate team transfers, allowing unauthorized removal of member access via playbook update
Attackers with playbook configuration permissions can bypass member management restrictions to remove access from unauthorized teams.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-4286?
CVE-2026-4286 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to check if {{team_id}} was being changed when updating playbooks, allowing users with only {{Manage Playbook Configurations}} permission to change a playbook's team, bypassing manage members restriction via PUT api. Mattermost Advisory ID: MMSA-2025-00552
Weakness: CWE-863
Which versions are affected by CVE-2026-4286?
11 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-plugin-playbooks and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-plugin-playbooks Go | All versions | 1.41.1-0.20260213020129-e1d6ec2c94e6 |
5 more packages
github.com/mattermost/mattermost-plugin-playbooks Go | All versions | 1.41.1-0.20260213020129-e1d6ec2c94e6 |
github.com/mattermost/mattermost-plugin-playbooks Go | All versions | 1.41.1-0.20260213020129-e1d6ec2c94e6 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-4286?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.11.14 or 11.5.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-4286 being exploited?
There is no known exploitation of CVE-2026-4286 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-gvg4-jhmr-6j23, GO-2026-5404.