# CVE-2026-42860: Open edx Enterprise Service: SSRF via SAML metadata URL in sync_provider_data endpoint

> An authenticated Enterprise Admin can trigger server-side requests to arbitrary URLs via SAML metadata configuration, potentially accessing internal resources.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-64cv-vxpr-j6vc, PYSEC-2026-58

## What is CVE-2026-42860?

CVE-2026-42860 is a high-severity server-side request forgery vulnerability in openedx edx-enterprise, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Open edx Enterprise Service app provides enterprise features to the Open edX platform. From 7.0.2 to 7.0.4, the sync_provider_data endpoint in SAMLProviderDataViewSet fetches SAML metadata from a URL stored in SAMLProviderConfig.metadata_source. An authenticated user with the Enterprise Admin role can set this field to an arbitrary URL via the SAMLProviderConfigViewSet PATCH endpoint, then trigger a server-side HTTP request by calling sync_provider_data. The fetch in fetch_metadata_xml() passes the URL directly to requests.get() with no scheme enforcement, IP filtering, or timeout. This vulnerability is fixed in 7.0.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-42860?

3 open source packages ship an affected version, including edx-enterprise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edx-enterprise` | PyPI | From 7.0.2 | 7.0.5 |
| `edx-enterprise` | PyPI | From 7.0.2 | 7.0.5 |
| `edx-enterprise` | PyPI | From 7.0.2 | 7.0.5 |

Products: Openedx Edx-Enterprise.

## How do I fix CVE-2026-42860?

Upgrade edx-enterprise to 7.0.5 or later.

## Is CVE-2026-42860 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42860 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42860 and fix it if it is affected.

What it is: CVE-2026-42860 is a high-severity server-side request forgery vulnerability in openedx edx-enterprise, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42860 exists.

Affected packages and fixed versions:
- edx-enterprise (PyPI): affected from 7.0.2; fixed in 7.0.5
- edx-enterprise (PyPI): affected from 7.0.2; fixed in 7.0.5
- edx-enterprise (PyPI): affected from 7.0.2; fixed in 7.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42860/ (Markdown: https://insights.sbomify.com/CVE-2026-42860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42860
- OSV: https://osv.dev/vulnerability/CVE-2026-42860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42860/
Summaries are generated and may contain mistakes; the official description above is the record.
