# CVE-2026-42863: Flowise: Mass Assignment in Chatflow Update Endpoint Allows Cross-Workspace AgentFlow Reassignment

> Authenticated users can reassign chatflows to other workspaces and modify visibility settings due to missing server-side validation in the update endpoint.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** GHSA-5wxp-qjgq-fx6m

## What is CVE-2026-42863?

CVE-2026-42863 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 8 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, a mass assignment vulnerability exists in the chatflow update endpoint of FlowiseAI. The endpoint allows clients to modify server-controlled properties such as deployed, isPublic, workspaceId, createdDate, and updatedDate when updating a chatflow object. Due to missing server-side validation and authorization checks, an authenticated user can manipulate internal attributes of a chatflow and reassign it to another workspace. This allows cross-workspace resource reassignment and unauthorized modification of deployment and visibility settings. This issue has been patched in version 3.1.2.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-42863?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.2 |
| `flowise` | npm | All versions | 3.1.2 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-42863?

Upgrade flowise to 3.1.2 or later.

## Is CVE-2026-42863 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42863 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42863 and fix it if it is affected.

What it is: CVE-2026-42863 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 8 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42863 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.2
- flowise (npm): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42863/ (Markdown: https://insights.sbomify.com/CVE-2026-42863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42863
- OSV: https://osv.dev/vulnerability/CVE-2026-42863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42863/
Summaries are generated and may contain mistakes; the official description above is the record.
