# CVE-2026-42864: FireFighter: Unauthenticated SSRF in Raid jira_bot endpoint allows IAM credential theft

> Unauthenticated attackers can exploit an SSRF vulnerability in the Jira bot endpoint to steal AWS IAM credentials from the server.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-fqvv-jvhr-g5jc, PYSEC-2026-339

## What is CVE-2026-42864?

CVE-2026-42864 is a critical server-side request forgery vulnerability in ManoManoTech firefighter-incident, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FireFighter is an incident management application. Prior to 0.0.54, the POST /api/v2/firefighter/raid/jira_bot endpoint (CreateJiraBotView) is reachable without authentication (permission_classes = [permissions.AllowAny]). Its attachments payload is fetched server-side via httpx.get() with no URL validation, then uploaded as an attachment on the Jira ticket that gets created. An unauthenticated caller able to reach the ingress can coerce the pod into fetching arbitrary URLs and exfiltrate the response as a Jira attachment. On EC2/EKS deployments that do not enforce IMDSv2, this allows theft of the temporary AWS credentials attached to the pod's IAM role. The docstring on the view claims a Bearer token is required, but the code does not enforce it. This vulnerability is fixed in 0.0.54.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-42864?

3 open source packages ship an affected version, including firefighter-incident.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `firefighter-incident` | PyPI | All versions | 0.0.54 |
| `firefighter-incident` | PyPI | All versions | 0.0.54 |
| `firefighter-incident` | PyPI | All versions | 0.0.54 |

## How do I fix CVE-2026-42864?

Upgrade firefighter-incident to 0.0.54 or later.

## Is CVE-2026-42864 being exploited?

There is no known exploitation of CVE-2026-42864 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42864 and fix it if it is affected.

What it is: CVE-2026-42864 is a critical server-side request forgery vulnerability in ManoManoTech firefighter-incident, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42864 in the wild and no public exploit code.

Affected packages and fixed versions:
- firefighter-incident (PyPI): affected all versions; fixed in 0.0.54
- firefighter-incident (PyPI): affected all versions; fixed in 0.0.54
- firefighter-incident (PyPI): affected all versions; fixed in 0.0.54

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42864/ (Markdown: https://insights.sbomify.com/CVE-2026-42864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42864
- OSV: https://osv.dev/vulnerability/CVE-2026-42864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42864/
Summaries are generated and may contain mistakes; the official description above is the record.
