{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42887 exists.","fix":"No fix has been published for CVE-2026-42887 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-42887 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42887 and fix it if it is affected.\n\nWhat it is: CVE-2026-42887 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42887 exists.\n\nAffected product: advplyr audiobookshelf. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42887/ (Markdown: https://insights.sbomify.com/CVE-2026-42887/index.md)","id":"CVE-2026-42887","markdown":"https://insights.sbomify.com/CVE-2026-42887/index.md","name":"CVE-2026-42887","record":{"aliases":["GHSA-cx29-ghq2-9cm4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Audiobookshelf server","requires_auth":"high_privilege","summary":"Administrators can inject malicious scripts into the login page, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.33.0, a stored cross-site scripting (XSS) vulnerability exists in the Login Page due to improper sanitization of the authLoginCustomMessage field of the /api/auth-settings endpoint. An attacker with administrative privileges can inject arbitrary HTML/JavaScript that will be rendered on the login page for all users. This vulnerability is fixed in 2.33.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Audiobookshelf: Stored Cross-Site Scripting in Login Page Custom Message","id":"CVE-2026-42887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Audiobookshelf: Path Traversal vulnerability in the audiobookshelf project","id":"CVE-2026-42888"},"packages":[],"prev":{"headline":"Audiobookshelf: Memory amplification DoS via oversized compressed details entry in backup upload","id":"CVE-2026-42886"},"products":["audiobookshelf"],"published":"2026-05-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-12","vendors":["advplyr"]},"summary":"Administrators can inject malicious scripts into the login page, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2026-42887/"}