# CVE-2026-42887: Audiobookshelf: Stored Cross-Site Scripting in Login Page Custom Message

> Administrators can inject malicious scripts into the login page, potentially compromising user sessions and data.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-cx29-ghq2-9cm4

## What is CVE-2026-42887?

CVE-2026-42887 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.33.0, a stored cross-site scripting (XSS) vulnerability exists in the Login Page due to improper sanitization of the authLoginCustomMessage field of the /api/auth-settings endpoint. An attacker with administrative privileges can inject arbitrary HTML/JavaScript that will be rendered on the login page for all users. This vulnerability is fixed in 2.33.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42887?


## How do I fix CVE-2026-42887?

No fix has been published for CVE-2026-42887 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42887 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42887 and fix it if it is affected.

What it is: CVE-2026-42887 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42887 exists.

Affected product: advplyr audiobookshelf. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42887/ (Markdown: https://insights.sbomify.com/CVE-2026-42887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42887
- OSV: https://osv.dev/vulnerability/CVE-2026-42887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42887/
Summaries are generated and may contain mistakes; the official description above is the record.
