# CVE-2026-42890: actual Allows Electron to Run As Node

> Attackers can bypass macOS Gatekeeper and execute arbitrary code by running the signed Actual.app binary as a Node.js REPL via environment variables.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** GHSA-7rvm-xjpp-63r9

## What is CVE-2026-42890?

CVE-2026-42890 is a medium-severity vulnerability in actualbudget actual, published on 12 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Actual is an open-source personal finance application. In the macOS desktop application version 25.x (built on Electron 39.2.7), the ELECTRON_RUN_AS_NODE fuse is not disabled, allowing an attacker who can place a file on disk or control command-line arguments to invoke the signed Actual.app binary with the ELECTRON_RUN_AS_NODE=1 environment variable set. This converts the application into a Node.js REPL capable of executing arbitrary code that inherits the application's entitlements and code signature, bypassing macOS Gatekeeper review. Version 26.5.0 patches the issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-42890?

2 open source packages ship an affected version, including actual.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actual` | npm | All versions | 26.5.0 |
| `actual` | npm | All versions | 26.5.0 |

## How do I fix CVE-2026-42890?

Upgrade actual to 26.5.0 or later.

## Is CVE-2026-42890 being exploited?

There is no known exploitation of CVE-2026-42890 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42890 and fix it if it is affected.

What it is: CVE-2026-42890 is a medium-severity vulnerability in actualbudget actual, published on 12 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42890 in the wild and no public exploit code.

Affected packages and fixed versions:
- actual (npm): affected all versions; fixed in 26.5.0
- actual (npm): affected all versions; fixed in 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42890/ (Markdown: https://insights.sbomify.com/CVE-2026-42890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42890
- OSV: https://osv.dev/vulnerability/CVE-2026-42890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42890/
Summaries are generated and may contain mistakes; the official description above is the record.
