# CVE-2026-4292: Privilege abuse in ModelAdmin.list_editable

> Attackers can create new database instances via forged POST requests in Django admin changelist forms using list_editable.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** BIT-django-2026-4292, CLSA-2026-1787220072, DEBIAN-CVE-2026-4292, ECHO-7fb5-d5d0-f779, GHSA-mmwr-2jhp-mc7j, MINI-88jv-m93g-p98g, PYSEC-2026-53, UBUNTU-CVE-2026-4292

## What is CVE-2026-4292?

CVE-2026-4292 is a low-severity missing authorization vulnerability in Djangoproject Django, published on 7 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30.
Admin changelist forms using `ModelAdmin.list_editable` incorrectly allowed new
instances to be created via forged `POST` data.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Cantina for reporting this issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-4292?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.30, 5.2.13, 6.0.4 |
| `django` | PyPI | From 4.2 | 4.2.30, 5.2.13, 6.0.4 |
| `django` | PyPI | From 4.2 | 4.2.30 |
| `django` | PyPI | From 5.2 | 5.2.13 |
| `django` | PyPI | From 6.0 | 6.0.4 |
| `Django` | PyPI | From 4.2 | 4.2.30 |
| `Django` | PyPI | From 5.2 | 5.2.13 |
| `Django` | PyPI | From 6.0 | 6.0.4 |

Products: Djangoproject Django.

## How do I fix CVE-2026-4292?

Upgrade django to a fixed version for your release line: 4.2.30, 5.2.13 or 6.0.4.

## Is CVE-2026-4292 being exploited?

There is no known exploitation of CVE-2026-4292 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4292 and fix it if it is affected.

What it is: CVE-2026-4292 is a low-severity missing authorization vulnerability in Djangoproject Django, published on 7 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-4292 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.30, 5.2.13, 6.0.4
- django (PyPI): affected from 4.2; fixed in 4.2.30, 5.2.13, 6.0.4
- django (PyPI): affected from 4.2; fixed in 4.2.30
- django (PyPI): affected from 5.2; fixed in 5.2.13
- django (PyPI): affected from 6.0; fixed in 6.0.4
- Django (PyPI): affected from 4.2; fixed in 4.2.30
- Django (PyPI): affected from 5.2; fixed in 5.2.13
- Django (PyPI): affected from 6.0; fixed in 6.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4292/ (Markdown: https://insights.sbomify.com/CVE-2026-4292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4292
- OSV: https://osv.dev/vulnerability/CVE-2026-4292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4292/
Summaries are generated and may contain mistakes; the official description above is the record.
