# CVE-2026-42926: NGINX ngx_http_proxy_v2_module vulnerability

> Attackers can inject frame headers and payload bytes to upstream peers when NGINX proxies HTTP/2 traffic with specific body settings.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 May 2026
- **Also known as:** BIT-nginx-2026-42926, BIT-nginx-gateway-2026-42926, DEBIAN-CVE-2026-42926, ECHO-64e0-d4ec-3b8b, GHSA-v43f-895r-chhh, MINI-5gj3-wj3v-54w5, MINI-5gvg-v9c4-ww8g

## What is CVE-2026-42926?

CVE-2026-42926 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When NGINX Open Source is configured to proxy HTTP/2 traffic by setting proxy_http_version to 2, and also uses proxy_set_body, an attacker may be able to inject frame headers and payload bytes to the upstream peer.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-172 (Improper Encoding or Decoding of Data)

## Which versions are affected by CVE-2026-42926?

2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 1.29.4 | 1.30.1 |
| `nginx-gateway` | Bitnami | From 1.29.4 | 1.30.1 |

Products: F5 Nginx Gateway Fabric, F5 Nginx Ingress Controller, F5 Nginx Instance Manager, F5 Nginx Open Source.

## How do I fix CVE-2026-42926?

Upgrade nginx to 1.30.1 or later.

## Is CVE-2026-42926 being exploited?

There is no known exploitation of CVE-2026-42926 in the wild and no public exploit code.

Public exploit code:

- Controlled NGINX HTTP/2 frame injection lab for CVE-2026-42926 patch validation and defensive research (github_poc): https://github.com/ikarolaborda/CVE2026-42926

## Other vulnerabilities in F5 NGINX Open Source

- [CVE-2026-42533](https://insights.sbomify.com/CVE-2026-42533/): NGINX Map directive and Regex matching vulnerability (critical 9.2)
- [CVE-2026-42530](https://insights.sbomify.com/CVE-2026-42530/): NGINX Open-Source ngx_http_v3_module vulnerability (critical 9.2)
- [CVE-2026-60005](https://insights.sbomify.com/CVE-2026-60005/): NGINX ngx_http_slice_module vulnerability (high 8.8)
- [CVE-2026-11311](https://insights.sbomify.com/CVE-2026-11311/): NGINX Gateway Fabric vulnerability (high 8.6)
- [CVE-2026-50107](https://insights.sbomify.com/CVE-2026-50107/): NGINX Gateway Fabric vulnerability (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42926 and fix it if it is affected.

What it is: CVE-2026-42926 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42926 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 1.29.4; fixed in 1.30.1
- nginx-gateway (Bitnami): affected from 1.29.4; fixed in 1.30.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42926/ (Markdown: https://insights.sbomify.com/CVE-2026-42926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42926
- OSV: https://osv.dev/vulnerability/CVE-2026-42926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42926/
Summaries are generated and may contain mistakes; the official description above is the record.
