{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 7 products.","exploited":"There is no known exploitation of CVE-2026-42934 in the wild and no public exploit code.","fix":"Upgrade nginx to 1.30.1 or later.","what":"CVE-2026-42934 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42934 and fix it if it is affected.\n\nWhat it is: CVE-2026-42934 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42934 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 0.3.50; fixed in 1.30.1\n- nginx-gateway (Bitnami): affected from 0.3.50; fixed in 1.30.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42934/ (Markdown: https://insights.sbomify.com/CVE-2026-42934/index.md)","id":"CVE-2026-42934","markdown":"https://insights.sbomify.com/CVE-2026-42934/index.md","name":"CVE-2026-42934","record":{"aliases":["ALPINE-CVE-2026-42934","AZL-86853","BELL-CVE-2026-42934","BIT-nginx-2026-42934","BIT-nginx-gateway-2026-42934","DEBIAN-CVE-2026-42934","ECHO-0618-45a8-483a","GHSA-6vmc-2wh4-77qp","MINI-3mr2-xh4h-f62q","MINI-5mhf-jf24-444j","MINI-c2gv-wc8f-v9j7","MINI-j3c9-x2v5-pwv9","MINI-wfmp-q7c9-f4r6","UBUNTU-CVE-2026-42934"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX web server","requires_auth":"none","summary":"Unauthenticated attackers can trigger a heap buffer over-read in NGINX, causing memory disclosure or service restarts when specific charset and proxy configurations are enabled.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"dos","vendor":"f5"},{"product":"nginx_gateway_fabric","vendor":"f5"},{"product":"nginx_ingress_controller","vendor":"f5"},{"product":"nginx_instance_manager","vendor":"f5"},{"product":"nginx_open_source","vendor":"f5"},{"product":"nginx_plus","vendor":"f5"},{"product":"waf","vendor":"f5"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When charset, source_charset, and charset_map and proxy_pass with disabled buffering (\"off\") directives are configured, unauthenticated attackers can send requests that with conditions beyond the attackers' control to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart.\n\n Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX ngx_http_charset_module vulnerability","id":"CVE-2026-42934","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Other in HYPER SBI 2","id":"CVE-2026-42936"},"packages":[{"ecosystem":"Bitnami","fixed":["1.30.1"],"introduced":["0.3.50"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2026-42934"},{"ecosystem":"Bitnami","fixed":["1.30.1"],"introduced":["0.3.50"],"last_affected":[],"package":"nginx-gateway","purl":"pkg:bitnami/nginx-gateway","source":"BIT-nginx-gateway-2026-42934"}],"prev":{"headline":"Unintended Proxy or Intermediary in Panduit IntraVUE by Pronetiqs","id":"CVE-2026-42933"},"products":["NGINX Open Source","NGINX Plus"],"published":"2026-05-13","related":[{"cvss_score":9.2,"headline":"NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability","id":"CVE-2026-42055","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":9.2,"headline":"NGINX ngx_http_rewrite_module vulnerability","id":"CVE-2026-42945","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":8.3,"headline":"NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerability","id":"CVE-2026-42946","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":6.9,"headline":"NGINX ngx_quic_module vulnerability","id":"CVE-2026-40460","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":6.3,"headline":"NGINX ngx_http_charset_module vulnerability","id":"CVE-2026-48142","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":6.3,"headline":"NGINX ngx_http_ssl_module vulnerability","id":"CVE-2026-40701","kev_date_added":null,"published":"2026-05-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-08","vendors":["F5"]},"summary":"Unauthenticated attackers can trigger a heap buffer over-read in NGINX, causing memory disclosure or service restarts when specific charset and proxy configurations are enabled.","url":"https://insights.sbomify.com/CVE-2026-42934/"}