# CVE-2026-42934: NGINX ngx_http_charset_module vulnerability

> Unauthenticated attackers can trigger a heap buffer over-read in NGINX, causing memory disclosure or service restarts when specific charset and proxy configurations are enabled.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 8 Jun 2026
- **Also known as:** ALPINE-CVE-2026-42934, AZL-86853, BELL-CVE-2026-42934, BIT-nginx-2026-42934, BIT-nginx-gateway-2026-42934, DEBIAN-CVE-2026-42934, ECHO-0618-45a8-483a, GHSA-6vmc-2wh4-77qp, MINI-3mr2-xh4h-f62q, MINI-5mhf-jf24-444j, MINI-c2gv-wc8f-v9j7, MINI-j3c9-x2v5-pwv9, MINI-wfmp-q7c9-f4r6, UBUNTU-CVE-2026-42934

## What is CVE-2026-42934?

CVE-2026-42934 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When charset, source_charset, and charset_map and proxy_pass with disabled buffering ("off") directives are configured, unauthenticated attackers can send requests that with conditions beyond the attackers' control to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart.

 Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-42934?

2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 0.3.50 | 1.30.1 |
| `nginx-gateway` | Bitnami | From 0.3.50 | 1.30.1 |

Products: F5 Dos, F5 Nginx Gateway Fabric, F5 Nginx Ingress Controller, F5 Nginx Instance Manager, F5 Nginx Open Source, F5 Nginx Plus, F5 Waf.

## How do I fix CVE-2026-42934?

Upgrade nginx to 1.30.1 or later.

## Is CVE-2026-42934 being exploited?

There is no known exploitation of CVE-2026-42934 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Open Source

- [CVE-2026-42055](https://insights.sbomify.com/CVE-2026-42055/): NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability (critical 9.2)
- [CVE-2026-42945](https://insights.sbomify.com/CVE-2026-42945/): NGINX ngx_http_rewrite_module vulnerability (critical 9.2)
- [CVE-2026-42946](https://insights.sbomify.com/CVE-2026-42946/): NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerability (high 8.3)
- [CVE-2026-40460](https://insights.sbomify.com/CVE-2026-40460/): NGINX ngx_quic_module vulnerability (medium 6.9)
- [CVE-2026-48142](https://insights.sbomify.com/CVE-2026-48142/): NGINX ngx_http_charset_module vulnerability (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42934 and fix it if it is affected.

What it is: CVE-2026-42934 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42934 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 0.3.50; fixed in 1.30.1
- nginx-gateway (Bitnami): affected from 0.3.50; fixed in 1.30.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42934/ (Markdown: https://insights.sbomify.com/CVE-2026-42934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42934
- OSV: https://osv.dev/vulnerability/CVE-2026-42934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42934/
Summaries are generated and may contain mistakes; the official description above is the record.
