{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 7 products.","exploited":"There is no known exploitation of CVE-2026-42946 in the wild and no public exploit code.","fix":"Upgrade nginx to 1.30.1 or later.","what":"CVE-2026-42946 is a high-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42946 and fix it if it is affected.\n\nWhat it is: CVE-2026-42946 is a high-severity vulnerability in F5 NGINX Open Source, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42946 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 0.8.42; fixed in 1.30.1\n- nginx-gateway (Bitnami): affected from 0.8.42; fixed in 1.30.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42946/ (Markdown: https://insights.sbomify.com/CVE-2026-42946/index.md)","id":"CVE-2026-42946","markdown":"https://insights.sbomify.com/CVE-2026-42946/index.md","name":"CVE-2026-42946","record":{"aliases":["ALPINE-CVE-2026-42946","AZL-86859","BELL-CVE-2026-42946","BIT-nginx-2026-42946","BIT-nginx-gateway-2026-42946","CLSA-2026-1781092483","CLSA-2026-1782139370","CLSA-2026-1782160000","CLSA-2026-1785422875","CLSA-2026-1790072773","CLSA-2026-1790072954","CLSA-2026-1790073266","CLSA-2026-1790328963","CLSA-2026-1790329264","CLSA-2026-1790332938","DEBIAN-CVE-2026-42946","ECHO-ed65-1c33-bea3","GHSA-fm65-xrrr-c358","MINI-36cw-64pv-45c3","MINI-j2c2-f6xw-pv24","MINI-m8r6-qqjx-xxq3","MINI-vfvv-5w2h-qj6f","MINI-w76h-59w4-5ffq","ROOT-OS-ALPINE-315-CVE-2026-42946","ROOT-OS-ALPINE-320-CVE-2026-42946","UBUNTU-CVE-2026-42946"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX web server","requires_auth":"none","summary":"An attacker with MITM capabilities can read NGINX worker memory or cause a restart when SCGI or UWSGI modules are configured.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"dos","vendor":"f5"},{"product":"nginx_gateway_fabric","vendor":"f5"},{"product":"nginx_ingress_controller","vendor":"f5"},{"product":"nginx_instance_manager","vendor":"f5"},{"product":"nginx_open_source","vendor":"f5"},{"product":"nginx_plus","vendor":"f5"},{"product":"waf","vendor":"f5"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-823","name":"Use of Out-of-range Pointer Offset"},{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"}],"description":"A vulnerability exists in the ngx_http_scgi_module and ngx_http_uwsgi_module modules that may result in excessive memory allocation or an over-read of data. When scgi_pass or uwsgi_pass is configured, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to read the memory of the NGINX worker process or restart it.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX ngx_http_scgi_module and ngx_http_uwsgi_module vulnerability","id":"CVE-2026-42946","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Naxclow IoT Platform Authorization bypass through User-Controlled key","id":"CVE-2026-42947"},"packages":[{"ecosystem":"Bitnami","fixed":["1.30.1"],"introduced":["0.8.42"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2026-42946"},{"ecosystem":"Bitnami","fixed":["1.30.1"],"introduced":["0.8.42"],"last_affected":[],"package":"nginx-gateway","purl":"pkg:bitnami/nginx-gateway","source":"BIT-nginx-gateway-2026-42946"}],"prev":{"headline":"NGINX ngx_http_rewrite_module vulnerability","id":"CVE-2026-42945"},"products":["NGINX Open Source","NGINX Plus"],"published":"2026-05-13","related":[{"cvss_score":9.2,"headline":"NGINX ngx_http_proxy_v2_module and ngx_http_grpc_module vulnerability","id":"CVE-2026-42055","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":9.2,"headline":"NGINX ngx_http_rewrite_module vulnerability","id":"CVE-2026-42945","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":6.9,"headline":"NGINX ngx_quic_module vulnerability","id":"CVE-2026-40460","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":6.3,"headline":"NGINX ngx_http_charset_module vulnerability","id":"CVE-2026-48142","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":6.3,"headline":"NGINX ngx_http_ssl_module vulnerability","id":"CVE-2026-40701","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":6.3,"headline":"NGINX ngx_http_charset_module vulnerability","id":"CVE-2026-42934","kev_date_added":null,"published":"2026-05-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["F5"]},"summary":"An attacker with MITM capabilities can read NGINX worker memory or cause a restart when SCGI or UWSGI modules are configured.","url":"https://insights.sbomify.com/CVE-2026-42946/"}